Contributor
Contributor

can't apply auto-negotiation to Intel 82599 10 Gigabit port..

~ # esxcli network nic list

Name    PCI Device     Driver  Link  Speed  Duplex  MAC Address         MTU  Description                                       

------  -------------  ------  ----  -----  ------  -----------------  ----  ---------------------------------------------------------------

vmnic0  0000:002:00.0  tg3     Up     1000  Full    3c:a8:2a:12:2a:24  1500  Broadcom Corporation NetXtreme BCM5719 Gigabit Ethernet

vmnic1  0000:002:00.1  tg3     Up     1000  Full    3c:a8:2a:12:2a:25  1500  Broadcom Corporation NetXtreme BCM5719 Gigabit Ethernet

vmnic2  0000:002:00.2  tg3     Down      0  Full    3c:a8:2a:12:2a:26  1500  Broadcom Corporation NetXtreme BCM5719 Gigabit Ethernet

vmnic3  0000:002:00.3  tg3     Down      0  Full    3c:a8:2a:12:2a:27  1500  Broadcom Corporation NetXtreme BCM5719 Gigabit Ethernet

vmnic4  0000:005:00.0  ixgbe   Down      0  Half    8c:dc:d4:b0:97:18  1500  Intel Corporation 82599 10 Gigabit Dual Port Network Connection <---- connected to L2SW.

vmnic5  0000:005:00.1  ixgbe   Down      0  Half    8c:dc:d4:b0:97:19  1500  Intel Corporation 82599 10 Gigabit Dual Port Network Connection

vmnic6  0000:00b:00.0  ixgbe   Down      0  Half    8c:dc:d4:b0:94:88  1500  Intel Corporation 82599 10 Gigabit Dual Port Network Connection

vmnic7  0000:00b:00.1  ixgbe   Down      0  Half    8c:dc:d4:b0:94:89  1500  Intel Corporation 82599 10 Gigabit Dual Port Network Connection

~ # vmware -lv

VMware ESXi 5.5.0 build-2403361

VMware ESXi 5.5.0 Update 2

~ # esxcli software vib list | grep ixgbe

net-ixgbe                      3.21.4-1OEM.550.0.0.1331820            Intel            VMwareCertified   2015-09-10

~ # ethtool vmnic4

Settings for vmnic4:

        Supported ports: [ FIBRE ]

        Supported link modes:

        Supports auto-negotiation: No

        Advertised link modes:  Not reported

        Advertised auto-negotiation: No

        Speed: Unknown! (65535)

        Duplex: Unknown! (255)

        Port: FIBRE

        PHYAD: 0

        Transceiver: external

        Auto-negotiation: off

        Supports Wake-on: d

        Wake-on: d

        Current message level: 0x00000007 (7)

        Link detected: no

~ # esxcfg-nics -a vmnic4

Error: Invalid argument: Invalid argument <-- here is issue for me..

0 Kudos
3 Replies
Hot Shot
Hot Shot

This error is coming because the driver does not support auto negotiation.

Can you try "ethtool --pause vmnic0 autoneg on" and then try the command

0 Kudos
Contributor
Contributor

Thank you for the reply, I tried it bit no change autonego status...

~ # ethtool -i vmnic4

driver: ixgbe

version: 3.21.4iov

firmware-version: 0x80000811, 1.1067.0

bus-info: 0000:05:00.0

~ #

~ #

~ # ethtool --show-pause vmnic4

Pause parameters for vmnic4:

Autonegotiate:  on

RX:             on

TX:             on

~ #

~ # ethtool --pause vmnic4 autoneg off

~ # ethtool --show-pause vmnic4

Pause parameters for vmnic4:

Autonegotiate:  off

RX:             on

TX:             on

~ #

~ # ethtool --pause vmnic4 autoneg on

~ #

~ # ethtool --show-pause vmnic4

Pause parameters for vmnic4:

Autonegotiate:  on

RX:             on

TX:             on

~ # esxcfg-nics -a vmnic4

Error: Invalid argument: Invalid argument <--still issue...

~ #

~ # ethtool vmnic4

Settings for vmnic4:

        Supported ports: [ FIBRE ]

        Supported link modes:

        Supports auto-negotiation: No

        Advertised link modes:  Not reported

        Advertised auto-negotiation: No

        Speed: Unknown! (65535)

        Duplex: Unknown! (255)

        Port: FIBRE

        PHYAD: 0

        Transceiver: external

        Auto-negotiation: off

        Supports Wake-on: d

        Wake-on: d

        Current message level: 0x00000007 (7)

        Link detected: no

~ #

~ # esxcli hardware pci list | grep mnic4 -A30

   VMkernel Name: vmnic4

   Vendor Name: Intel Corporation

   Device Name: 82599 10 Gigabit Dual Port Network Connection

   Configured Owner: Unknown

   Current Owner: VMkernel

   Vendor ID: 0x8086

   Device ID: 0x10fb

   SubVendor ID: 0x103c

   SubDevice ID: 0x17d3

   Device Class: 0x0200

   Device Class Name: Ethernet controller

   Programming Interface: 0x00

   Revision ID: 0x01

   Interrupt Line: 0xff

   IRQ: 255

   Interrupt Vector: 0x34

   PCI Pin: 0x00

   Spawned Bus: 0x00

   Flags: 0x0201

   Module ID: 4121

   Module Name: ixgbe

   Chassis: 0

   Physical Slot: 1

   Slot Description: PCI-E Slot 1

   Passthru Capable: true

   Parent Device: PCI 0:0:2:0

   Dependent Device: PCI 0:5:0:0

   Reset Method: Function reset

   FPT Sharable: true

000:005:00.1

~ # esxcli software vib list | grep ixgbe

net-ixgbe                      3.21.4-1OEM.550.0.0.1331820            Intel            VMwareCertified   2015-09-10

0 Kudos
Contributor
Contributor

We have the same issue with vmware 6 and after doing some digging I believe the problem may be that the 82599 Intel card can only receive auto negotiation frames....it does not transmit auto negotiation frames, hence it can not be set to auto negotiate outgoing traffic...

per Intel's fact sheet on this card:

"The 82599 supports reception of extended base page and next page

auto-negotiation frames but does not transmit

next page auto-negotiation frames..."

Ref Link:

http://www.intel.com/content/dam/www/public/us/en/documents/datasheets/82599-10-gbe-controller-datas...

3.7.4

Auto Negotiation For Backplane Ethernet

and Link Setup Features

Can someone with more knowledge of vmware confirm...?

0 Kudos