billdossett
Enthusiast
Enthusiast

application server and SQL server on same box fails

Hi,

I have a IIS application with SQL backend on ESXi5.1.  When I run them on the same host it fails after about 5 to 10 minutes.  I can still ping between them, but can't make an ODBC connection.  If I migrate either of the vms to another host, then it starts working again, and appears, to keep working.  A friend told me that this can be an issue as they are on the same vswitch and as it responds so fast that it basically gets jammed.  Has anyone else heard of this and if so is there any way to fix it?  As i only have two hosts at the moment, it means I can't take one down for maintenance...  I am addig  a third host soon, so if that's the case then I can work around it, but it certainly seems strange.


Thanks

Bill

Bill Dossett VCP4, VCP5, VCAP-DCA 5, VCAP-DCD5 I'm amazed sheeps' clothing is even made in wolf sizes. That's just asking for trouble.
0 Kudos
2 Replies
jdptechnc
Expert
Expert

Bill Dossett wrote:

Hi,

I have a IIS application with SQL backend on ESXi5.1.  When I run them on the same host it fails after about 5 to 10 minutes.  I can still ping between them, but can't make an ODBC connection.  If I migrate either of the vms to another host, then it starts working again, and appears, to keep working.  A friend told me that this can be an issue as they are on the same vswitch and as it responds so fast that it basically gets jammed.  Has anyone else heard of this and if so is there any way to fix it?  As i only have two hosts at the moment, it means I can't take one down for maintenance...  I am addig  a third host soon, so if that's the case then I can work around it, but it certainly seems strange.


Thanks

Bill

Not saying your friend is wrong, but I have never heard of this.  I have run similar configurations in the past and have not had these issues.

When you say "it" fails, I wonder where in the chain of communication it is failing?  Can the IIS server telnet to the the TCP port on the SQL Server?  Does  SQL Server see the attempts to initiate the connection at all?

Please consider marking as "helpful", if you find this post useful. Thanks!... IT Guy since 12/2000... Virtual since 10/2006... VCAP-DCA #2222
0 Kudos
billdossett
Enthusiast
Enthusiast

after it has failed, the app server can ping the sql server, but no, it can not telnet on the sql port... it's like the port has dissappeared.  There is nothing in the event logs or kernel logs as far as I can tell.  Try to test the ODBC DSN fails also.  Rebooting the app server seems to clear the problem which is strange, I would think the SQL server would need a boot.  Dunno, it was really frustrating as this is a fairly important production system we were virtualizing and pretty much had egg all over my face after 3 days of trying different stuff to get it working.

Cheers

Bill

Bill Dossett VCP4, VCP5, VCAP-DCA 5, VCAP-DCD5 I'm amazed sheeps' clothing is even made in wolf sizes. That's just asking for trouble.
0 Kudos