Highlighted
Contributor
Contributor

XFS and RHEL7 guest os

Hi All,

Just trying to find some help in troubleshooting an issue we are having.

When we have a client do an rsync to a XFS partition on a RHEL 7 guest , it's causing the guest vm to hang and the only way to recover is to reboot the host.

the host is VMware ESXi, 6.5.0, 5969303, we need to patch soon anyway to bring it up to the latest security levels.

The guest OS is up to date as well.  We don't have this issue with RHEL6 guest, just RHEL7.

We have done tools, vm hardware upgrades etc OS tuning, looked into the java setting for how large the  the underlying datastore can be, max amount of storage presented etc.

I'll go over the logs again, but for the moment I'm going to swap it to ext4 and see how that goes.

0 Kudos
5 Replies
Highlighted
Hot Shot
Hot Shot

What's the rsync configuration? Are you using any rsync packets on top of regular rsync? Any chance of uploading the guest OS logs?

Cheers,

Paul Wilk

Cheers, Paul Wilk
0 Kudos
Highlighted
Enthusiast
Enthusiast

i have same problem. i have attached the logs.

Christopher Sibug
0 Kudos
Highlighted
Expert
Expert

Can you check vmkerenel.log during the rsync activity.

There is known issue as per where host hangs during i/o operations:

VMware Knowledge Base

0 Kudos
Highlighted
Contributor
Contributor

Hi,

So it turns out (well so far so good) it's due to the template server being built with e1000 cards and they don't seem to be supported under esxi 6.5.  I've since swapped the cards to vmxnet3 and things seem to be running better.  It also means i need to swap about 20 more nics to ones that wont have issues

0 Kudos
Highlighted
Expert
Expert

Good to hear.

Try using PowerCli to make the changes:

pastedImage_0.png

0 Kudos