joergriether
Hot Shot
Hot Shot

Windows 2008 R2 + ESX4 + vCenter Client Console = FREEZE

Hello,

i reproduced this several times now and also found a coressponding thread in the microsoft newsgroups, ( http://social.technet.microsoft.com/Forums/en-US/windowsserver2008r2general/thread/bc0f3c12-eda7-440... ) so here you go:

Install a fresh W2008 R2 to an ESX4 machine, do this all with vCenter Client Console, not with reomte RDP. Add the role

Remote-Desktop-Services to the newly created W2008 R2 machine, reboot, after reboot when the machine tries to finish

the changes (after logon) it totally freezes.

Now the interesting part on that:

If you log on via RDP after the reboot (oh yeah, you urgently need to turn rdp on before reboot!!!), then

the installer of the role WILL FINISH!!!

Now how strange is that? Smiley Wink

Any ideas?

best,

Joerg

0 Kudos
126 Replies
Penic_Albin
Hot Shot
Hot Shot

Did you also try to reproduce this issue on physical machine?

If you find this information useful, please award points for "correct" or "helpful".

If you find this information useful, please award points for "correct" or "helpful".
0 Kudos
joergriether
Hot Shot
Hot Shot

i wrote it only happens in the console of vcenter client thus it´s absolutely vmware specific!

0 Kudos
sr_whq
Contributor
Contributor

Please just wait until W2K8 R2 is final (as is Windows 7, Server 2008 R2 currently is work in progress, beta).

Writing to the VMware community about problems with a Microsoft beta / RC version is in my opinion kinda useless. If you experience this problem only in vCenter Console, please recheck the whole thing when W2K8 is finished and out on MSDN. If the problem then still exists (but does also not exist when installing the server on bare metal), please return here.

Please don't feel offended - I really like the way you study and describe your situation.

Regards,

Mike

0 Kudos
joergriether
Hot Shot
Hot Shot

With all due respect, but W2008R2-RC is actually experimentally supported witgh ESX4 and the only reason this is so: VMware needs urgently feedback with these features. So I have to admit I am quite alienated by your post.

Regards,

Joerg

0 Kudos
sr_whq
Contributor
Contributor

Alienated? Aha - thank you. A question: If VMware urgently needs feedback for W2K8R2 under ESX4, so why none of the Pro-guys has entered this thread yet?

Another time the only important question: Did you try to reproduce this with an installation of the RC on bare metal?

As long as you didn't, you needn't come here in my private personal opinion (which you may again experience as, erhm, alienating).

Smiley Happy)

0 Kudos
Vesku80
Contributor
Contributor

Hello,

Seems like the problem continues with Windows 2008 R2 RTM. I haven't tested with bare metal server, but it's quite clear that the problem is with VmWare. I noticed that if you don't have VmWare Tools installed, the Resume Configuration Wizard goes through without a problem. I know that Window 7 and Windows 2008 R2 support is only experimental, but this is quite a nasty problem. Hope will see a fix soon...

Best regards,

Veli-Matti

0 Kudos
RParker
Immortal
Immortal

i wrote it only happens in the console of vcenter client thus it´s absolutely vmware specific!

Funny thing about errors, if they are reproducible why don't WE have the same problem? It might be specific for YOUR hardware running ESX, but it's NOT VM Ware specific. If it were it would happen to EVERYONE running Windows 2008 R2.

Probably a combination of the machine where you are running the VI Client (that's my guess) and your video card driver, that's the problem.

0 Kudos
RParker
Immortal
Immortal

I know that Window 7 and Windows 2008 R2 support is only experimental, but this is quite a nasty problem. Hope will see a fix soon...

I have one of my DC's setup as Windows 2008 R2. It's not a problem, it could be related to the hardware you are running VI Client on. It doesn't hang or freeze for me. Therefore, it must be a specific combination, and NOT a VM Ware issue, it's only on certain machines.

0 Kudos
joergriether
Hot Shot
Hot Shot

ok, while you are at it, let´s take a look at my further investigations:

I tested THIS with a dell r710 AND with a dell 2850 AND with a dell 2950. ESX Version was ESX4 RTM and the latest patched Release (175625).

Results: Freeze! Maybe it´s related to dell hardware, i don´t know, because i only have dell in my datacenter.

regards

Joerg

0 Kudos
tWiZzLeR
Enthusiast
Enthusiast

I can verify that I am having the same issue and that it happens with both Windows 7 RTM as well as Windows 2008 R2 RTM. What's interesting is that all three of my ESX 4 (fully patched) servers are Dell PE 2950 as well. I wonder if this is a Dell hardware + ESX issue? Anyone have any ideas for me to try?

0 Kudos
gamania
Contributor
Contributor

i have the same problem, and we are using Dell 1950/2950 as well.

0 Kudos
tWiZzLeR
Enthusiast
Enthusiast

I should give a little more info on my specific freezing issue: I can logon to Windows 7/2008 R2 without issue and I can start using the VM without issue, but at some random point (5 - 60 minutes) the vSphere console will freeze. This does not happen if I use remote desktop, rather ONLY via the vSphere console.

I should have also mentioned that I had the same issue when running on ESX 3.5 but ONLY with Windows 7 and 2008 R2 (they were beta and RC builds at that time).

Message was edited by: tWiZzLeR

0 Kudos
DMcCoy
Contributor
Contributor

I am also seeing a complete freeze in 2008 R2 (RTM) machines at random times (Machines stop responding completely, can't ping etc.). I am still creating a template server so have not tried with RDP to see if the issue is eliminated. Dell R710s. No issues with plain 2008, but those are old HW versions and not using vmxnet3 etc.

0 Kudos
DMcCoy
Contributor
Contributor

Ah I've got the firewall on still, which explains the no pings :smileylaugh:

I shall enable RDP and try and crash it and see if I can still get it. It happens when browsing folders in explorer so should be quick to crash again.

There we go, took about 60 seconds to crash it (browsing to system32/sysprep folder a few times in a couple of explorer windows). It's partially alive, I can get to the RDP login screen (once), but am unable to complete the login. Remote management tools work but I haven't been able find much.

0 Kudos
robotdog
Contributor
Contributor

I'm having a similar issue...

1. Dell 2950

2. ESXi 3.5

3. Windows 2008 R2 Enterprise RTM trying to to enable Remote desktop services - also enabled the desktop experience for audio and video support - maybe related?

After reboot, it attempts to finish with the Resuming Configuration box and it then freezes hard.

0 Kudos
culmor
Contributor
Contributor

Same issue with RC and RTM;

- Dell R710, 24GB RAM, VMware Tools installed

- Working via the VMware console = freezing.

Same Config as above minus VMware console

- no issues (rdp enabled)

As noted by others RDP works fine

0 Kudos
axmentor
Contributor
Contributor

I have the same freezing issue with ESX 4 B175625 and Windows 2008R2 RTM on HP DL380G5. It is not only a DELL issue.

Henrik

0 Kudos
DMcCoy
Contributor
Contributor

Someone pointed this out to me on another forum.

As if by magic a KB appeared!

http://kb.vmware.com/kb/1011709

0 Kudos
tWiZzLeR
Enthusiast
Enthusiast

Someone pointed this out to me on another forum.

As if by magic a KB appeared!

An issue with the video driver included with the VMware Tools makes total sense as the problem only rears its' ugly head when using the console! If you using remote desktop or not connected via the console the VM works just fine. I guess this is ehy support for Windows 7/2008 R2 is still expiramental as all of the bugs haven't been worked out yet.

Someone at VMware should update that KB article to include Windows 2008 R2 as well.

0 Kudos