romatlo
Enthusiast
Enthusiast

Why vsphere cluster hosts have yellow triangles?

Jump to solution

I've created a vsphere cluster with two vsphere 5 hosts in vmware workstation 7 similar to this demo.  http://vimeo.com/7560591

Everything was fine until I created the cluster, enabled HA, DRS, etc.  Now I have these yellow triangles on the hosts, but no alarms.  Also the Summary General information is all zeros.

See attached pic.

Would anyone have suggestions?

1 Solution

Accepted Solutions
Dave_Mishchenko
Immortal
Immortal

No problem.  You can ignore them.  For  the network one see this - http://kb.vmware.com/kb/1004700.

View solution in original post

0 Kudos
12 Replies
Dave_Mishchenko
Immortal
Immortal

The hosts aren't actually in the cluster.  You might want to select the datacenter or vCenter level and check for alarms at that level.

romatlo
Enthusiast
Enthusiast

Yes, thank you.  I am just realizing that I had not added the hosts to the cluster.  I dragged an dropped them and managed to get them added but still have the triangles...I'll keep looking.

THANKS!

0 Kudos
Dave_Mishchenko
Immortal
Immortal

I'd check the Summary and Configuration tabs for the hosts.  You might have a configuration error which would show up there.

romatlo
Enthusiast
Enthusiast

Thanks again!  This is my first time creating a cluster and iSCSI share storage.  I am doing all of this in vmware workstation and Openfiler...

I was able to get the hosts added to cluster, but still show warnings.  I can not find the details of the warnings...

I suspect it has something to do with HA or DRS but not sure.  I've attached a couple more pics of my configuration including networking and storage in case you see anything that stands out.  THANK YOU!

0 Kudos
Dave_Mishchenko
Immortal
Immortal

If you look towards the right hand corner of the vSphere client do the see the warning symbol there?  If so you can click on it to display warnings.

0 Kudos
romatlo
Enthusiast
Enthusiast

I do not see the warnings option to the right hand corner.

But when I click on each specific host and then Summary, I do see a configuration issues box.  (attached)

I guess this is it?  Thanks again for hanging around Smiley Happy

0 Kudos
Dave_Mishchenko
Immortal
Immortal

No problem.  You can ignore them.  For  the network one see this - http://kb.vmware.com/kb/1004700.

0 Kudos
romatlo
Enthusiast
Enthusiast

Thank You!  I have marked this thread as correct answer.  I will review and follow the article.

If you know of a way to clear the warnings, let me know.  Smiley Happy

0 Kudos
Dave_Mishchenko
Immortal
Immortal

The article will help with the network warning.  For the other check out the tips here - http://communities.vmware.com/message/1816089#1816089.

0 Kudos
nexusguy
Contributor
Contributor

Hello Romatio

       I know this is probably old but the warning sign is because you SSH Turned on on the box here is a link to clear it ->

To disable these warnings using vSphere Client:

  1. Select the ESXi host from the Inventory.
  2. Click the Configuration tab.
  3. Click Advanced Settings in the Software menu.
  4. Navigate to UserVars > UserVars.SuppressShellWarning.
  5. Set the value from 0 to 1.
  6. Click OK.

To disable these warnings using esxcli:

  1. Connect to the ESXi host through SSH using root credentials.
  2. Run this command:

    vim-cmd hostsvc/advopt/update UserVars.SuppressShellWarning long 1

To enable these warnings using esxcli:

  1. Connect to the ESXi host through SSH using root credentials.
  2. Run this command:

    vim-cmd hostsvc/advopt/update UserVars.SuppressShellWarning long 0

To disable SSH and warning using vSphere Web Client:

  • Disable remote access to the ESXi 5.x host
    1. From the vSphere Web Client, select vCenter from the Home menu.
    2. Select Hosts and Clusters under the Inventory Trees.
    3. Expand the tree in the left pane of the vSphere Web Client.
    4. Click the ESXi host with the yellow exclamation and click the Manage tab.
    5. Click Settings and highlight Security Profile.
    6. Scroll to Services and click Edit.
    7. Highlight ESXi Shell and click Stop.
    8. Repeat for SSH, then press OK.

  • Disable the Warning message
    1. From the vSphere Web Client, select vCenter from the Home menu.
    2. Select Hosts and Clusters under the Inventory Trees.
    3. Expand the tree in the left pane of the vSphere Web Client.
    4. Click the ESXi host with the yellow exclamation and click the Manage tab.
    5. Click Settings and highlight Advanced System Settings.
    6. Locate the parameter UserVars.SuppressShellWarning and click the pencil icon to edit.
    7. Change the value to 1 and press OK.
julio_avila
Contributor
Contributor

This worked nexusguy! Thanks!

0 Kudos
SuperVertrix
Contributor
Contributor

Excellent nexusguy!

Thank worked for me as well.

Cheers!

 

0 Kudos