Highlighted
Contributor
Contributor

Why does ESXi 6 host only see 1 LUN through HBA 12 go SAS ?

Hello,

I Installed our new small virtual architecture with 2 x D430 and one direct storage SCV2020. Through my vcenter appliance I can see the Avago (LSI Logic) Dell 12Gbps SAS HBA and succedeed in mounting 1 datastore but my other LUNs can't be seen even after one reboot and a new discovery. My cluster HA was also active but after 1 of my 2 hosts reboot the rebooted host does not see the HBA anymore and the cluster is no longer active...

I've checked my esx

esxcfg-scsidevs –a :

vmhba2  lsi_msgpt3        link-n/a sas.51866da05571e700 (0000:05:00.0) Avago (LSI Logic) Dell 12Gbps SAS HBA external


Driver version

vmkload_mod -s lsi_msgpt3 | grep Version :

Version: 10.00.03.00-1OEM.600.0.0.2768847

Vendor info :

vmkchdev -l |grep vmhba2

0000:05:00.0 1000:0097 1028:1f46 vmkernel vmhba2

GET ESX VERSION INFO vmware –vl

  VMware ESXi 6.0.0 build-3568940
VMware ESXi 6.0.0 Update 1

On my vmware site the recommended versions according to my vendor ids are : (so the first is the one installed on my system)

ESXi 6.0 U1  
       lsi_msgpt3 version 10.00.03.00-1OEM   9.17.20.07     Partner Async          
        ESXi 6.0 U1    scsi-mpt3sas version 10.00.02.00-1OEM 9.17.20.07     Partner Async          
        ESXi 6.0 U1    lsi_msgpt3 version 08.00.01.00-1OEM   07.17.02.00    Partner Async          
        ESXi 6.0 U1    lsi_msgpt3 version 08.00.01.00-1OEM   07.17.02.00    Partner Async          
        ESXi 6.0 U1    mpt3sas version 08.00.01.00.1vmw      07.17.02.00    Partner Async          
        ESXi 6.0 U1    lsi_msgpt3 version 06.255.12.00-8vmw  N/A     VMware Inbox           
        ESXi 6.0 U1    mpt3sas version 04.00.00.00.1vmw      03.00.08.00    Partner Async

Should i change of driver ? Or is it another problem?

Thank you.

0 Kudos
1 Reply
Highlighted
Enthusiast
Enthusiast

It's probably solved yet but if anyone was looking for it.

Use mpt3sas for Dell 12Gbps SAS HBA and SCv2020 - see Dell Servers with vSphere 5.5/6.0 and Compellent SCv2020 HBA SAS conectivity  for more info.

0 Kudos