vm7user
Enthusiast
Enthusiast

Why RSS Capable is False on VMXNET3?

Hello,

I have VM with VMXNET3 and Windows Server 2016

Receive Side Scaling is Enabled:

PS C:\Windows\system32> Get-NetAdapterRss

Name                                            : Ethernet0

InterfaceDescription                            : vmxnet3 Ethernet Adapter

Enabled                                         : True

NumberOfReceiveQueues                           : 4

Profile                                         : NUMAStatic

BaseProcessor: [Group:Number]                   : 0:0

MaxProcessor: [Group:Number]                    : 0:3

MaxProcessors                                   : 4

RssProcessorArray: [Group:Number/NUMA Distance] : 0:0/0  0:1/0  0:2/0  0:3/0

IndirectionTable: [Group:Number]                :

C:\Windows\system32>netsh int tcp show global

Querying active state...

TCP Global Parameters

----------------------------------------------

Receive-Side Scaling State          : enabled

Chimney Offload State               : disabled

NetDMA State                        : disabled

Direct Cache Access (DCA)           : disabled

Receive Window Auto-Tuning Level    : normal

Add-On Congestion Control Provider  : none

ECN Capability                      : enabled

RFC 1323 Timestamps                 : disabled

Initial RTO                         : 3000

Receive Segment Coalescing State    : enabled

Non Sack Rtt Resiliency             : disabled

Max SYN Retransmissions             : 2

TCP Fast Open                       : disabled

but, RSS not work on this adapter:

PS C:\Windows\system32> Get-SmbServerNetworkInterface

Scope Name Interface Index RSS Capable RDMA Capable Speed   IpAddress

---------- --------------- ----------- ------------ -----   ---------

*          3               False       False        10 Gbps 192.168.0.100

PS C:\Windows\system32> Get-SmbClientNetworkInterface

Interface Index RSS Capable RDMA Capable Speed    IpAddresses               Friendly Name

--------------- ----------- ------------ -----    -----------               -------------

3               False       False        10 Gbps  {192.168.0.100}            Ethernet0

2               False       False        100 Kbps {fe80::5efe:192.168.0.100} isatap.*******

Why RSS Capable is False???

0 Kudos
14 Replies
Stanley_
Enthusiast
Enthusiast

I have also problems with VMXNET3 and RSS. What I find out is that with VMtools 9.4.11 IndirectionTable: show all possible options.

But with any 10.x.x including the latest 10.1.0 vmtools is empty and same I can see in perfmon.

OS: Windows 2012 (clear installationfrom ISO)

with VMtools 9.4.11  VMXNET3 is RSS capable and indirect table  is full of options

0 Kudos
Mike_Parkay
Contributor
Contributor

I am having the same problem with server 2012 r2.  Microsoft said it was the vmxnet3 dirver so I updated VMtools to 10.1.0 - still the same problem.  Can anyone help?

0 Kudos
Stanley_
Enthusiast
Enthusiast

we escalated to Microsoft and VMware support.. .. they escalated to engineering team..  -> ETA ?

waiting for new VMtools version.. I hope it will be fixed.

latest working VMtools are 9.4.15

0 Kudos
WallyL
Contributor
Contributor

Hey guys, drop down to vmxnet3 driver (version 1.5.2.0) and it will work again, at least on windows 2012 R2.

Were currently running this version on any servers that NEED to have RSS working properly. Our other servers are version 1.6.7.0.

I am currently looking into vmxnet3 driver (version 1.7.3.0) which is contained in the 6.5 version of tools build number 4449150.


We had this issue back in June 2016, were getting ready to upgrade to the December build for hp proliant.


Regards,
Wally

0 Kudos
Stanley_
Enthusiast
Enthusiast

this is what I wrote,

vmxnet3 driver 1.5.2.0  = vmtools 9.4.11 = working

also vmtools 9.4.15 are working .

but RSS is not working in vmtools 10.x.x

we already tested VMtools 10.1.0 = driver 1.7.3.1 and this was not working

0 Kudos
AartK
Contributor
Contributor

Same problem here with VMXNET3 driver 1.6.7.0 and VMtools 10.0.9

RSS = False in the Get-SMBClientNetworkInterface

But I am glad someone found a workaround but this need to be fixed ASAP.

0 Kudos
Stanley_
Enthusiast
Enthusiast

we have opened case with VMware, but still no ETA for fix.

I tested also the latest vmtools 10.1.5.. and still not working Smiley Sad

0 Kudos
rnolli
Contributor
Contributor

Still facing the same issue on the latest ESXI 6 version and also latest version of VMTools.

Did someone manage to fix this with any workarround or got any updates from VMware?

0 Kudos
Stanley_
Enthusiast
Enthusiast

last two VMtools 10.1.7 and 10.1.10 solve this RSS issue

Stanley_
Enthusiast
Enthusiast

last two VMtools 10.1.7 and 10.1.10 solve this RSS issue

VMware Tools 10.1.7 Release Notes

Resolved Issues

Receive Side Scaling is not functional for VMXNET3 on Windows 8 and Windows 2012 Server or later

This issue is caused by an update for the VMXNET3 driver that addressed RSS features added in NDIS version 6.30 rendering the functionality unusable. It is observed in VMXNET3 driver versions from 1.6.6.0 to 1.7.3.0. The issue affects Windows guest operating systems with VMware Tools 9.4.15 and later.

This issue is resolved in this release.

muhfugen
Contributor
Contributor

Stanley_ I can confirm that 10.1.7 does not fix this issue. I've yet to upgrade to 10.1.10 but I have a Server 2016 Core box which is experiencing it.

0 Kudos
Stanley_
Enthusiast
Enthusiast

Could you please share more details? like Get-NetAdapterRss

Thanks

akobus
Contributor
Contributor

Hi,

I try to enable RSS on Windows 2012 R2 servers running VMXNET3.

The case is that I have 5 servers where I want to enable RSS on. All vm's are more or less the same spec. (+-vCPU, Memory). All of them have >=4 logical CPU.

I of course had issues with the very old vm drivers/tools running so I failed at the first attempt. After upgrading VM tools to 10.1.7 I managed to enable RSS on the first server. Success!

pastedImage_1.png

...but I failed on the next ones and can't force them to be capable of RSS. I went thru all the steps enabling TCP global settings + enabling on the NIC Advanced setting.

Finally I've installed the latest VM Tools 10.2.0 but it still did not help. In fact I managed to effectively enable it at one more server but as part of the troubleshooting I lost it.

What I did was: netsh int tcp set global RSS=Disable at the stage when it worked (state as above), but the netsh int tcp set global RSS=Enable didn't bring it back as I expected.

pastedImage_4.png

Currently all the servers are running 10.2.0 Tools with VMXNET driver 1.7.3.7 but only one has RSS Capable = True and IndirectionTable filled in when I run the PowerShell cmdlets.

Any advices on what should be checked more? Should VM tools 10.2.0 solve all the issues with VMXNET3 and RSS on Server 2012 R2?

0 Kudos
oidz
Contributor
Contributor

I've had similar experience to you on this. Some VM's it seems to 'take' and RSS is enabled, on other it seems impossible to enable. I've tried vmtools 10.2 and adding a new NIC, no dice.

I'd be interested to hear if anyone finds a definitive solution to enabling this.

0 Kudos