VMware Cloud Community
meehanj
Contributor
Contributor

VpxClient has stopped working

I have recently received a Windows 7 64-bit lenovo laptop for a new job. It has all of the latest Windows updates installed (including .NET 4)

I installed the vSphere client (first 4.1, then 5.0) seemingly without issue. When I attempt to launch the client (either version) I immediately get a Windows notification that "VpxClient has stopped working" and I can either check online for a solution or close the program. Either way I cannot go any further.

2098040.png

Checking in the vpx log files I find these entries:

[        :startup :W: 1] 2012-08-14 15:43:12.418  Log for vSphere Client Launcher, pid=1252, version=5.0.0, build=build-455964, option=release
[        :Error   :W: 1] 2012-08-14 15:43:12.478  System.UnauthorizedAccessException: Attempted to perform an unauthorized operation.
   at Microsoft.Win32.RegistryKey.Win32Error(Int32 errorCode, String str)
   at Microsoft.Win32.RegistryKey.SetValue(String name, Object value, RegistryValueKind valueKind)
   at Microsoft.Win32.RegistryKey.SetValue(String name, Object value)
   at VpxClient.Program.RegisterClientMimeExtension()
[        :Error   :W: 1] 2012-08-14 15:43:12.487  A fatal unhandled error occurred in vi client
[        :Error   :W: 1] 2012-08-14 15:43:12.491  System.TypeLoadException: Could not load type 'shipEntryFieldId.IList' from assembly 'mscorlib, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089'.
   at System.Windows.Forms.Control.OnVisibleChanged(EventArgs e)
   at System.Windows.Forms.Control.SetVisibleCore(Boolean value)
   at System.Windows.Forms.Application.MarshalingControl..ctor()
   at System.Windows.Forms.Application.ThreadContext.get_MarshalingControl()
   at System.Windows.Forms.WindowsFormsSynchronizationContext..ctor()
   at System.Windows.Forms.WindowsFormsSynchronizationContext.InstallIfNeeded()
   at System.Windows.Forms.Control..ctor(Boolean autoInstallSyncContext)
   at System.Windows.Forms.ScrollableControl..ctor()
   at System.Windows.Forms.ContainerControl..ctor()
   at System.Windows.Forms.Form..ctor()
   at VpxClient.FormVpxConnect..ctor()
   at VpxClient.Program.Main(String[] commandline)

If anyone can offer any assistance it would be greatly appreciated. I have spent several futile hours searching and attempting various fixes.

Tags (2)
16 Replies
vmroyale
Immortal
Immortal

You might want to try to uninstall/re-install them both. Or you could try the Thinapped versions and see if they work.

Brian Atkinson | vExpert | VMTN Moderator | Author of "VCP5-DCV VMware Certified Professional-Data Center Virtualization on vSphere 5.5 Study Guide: VCP-550" | @vmroyale | http://vmroyale.com
Reply
0 Kudos
Ardnatur
Contributor
Contributor

This topic might be a little old but I had a very similar problem recently - Vsphere Client (5.0) refused to launch, just a meaningless "VpxClient has stopped working" message pops up briefly with no further explanation.

I eventually found that a Windows Update (KB2729452) seemed to be the cause, having broken mscorlib.dll

I followed the instructions at http://support.microsoft.com/kb/929833 to find the culprit and when I removed the update (twice!) it all started working again.

(all attempts to replace the mscorlib.dll had no effect but uninstalling the update did the trick)

Hope this helps someone else finding this thread.

Reply
0 Kudos
mikemalter
Contributor
Contributor

Same thing happened to me.  I did an windows update and Aero was broken because of it so I applied my restore point.  The vSphere would not come back and it was not until I uninstalled KB2729452 that it started working again.  I'm compiling a list of KB's to never install.  What is the old saying, Windows isn't done till vSphere won't run.

Reply
0 Kudos
beast22
Contributor
Contributor

I had the same problem. Windows update turned up UAC to the highest setting. I tried to run as admin and it worked, turned down UAC and the problem was resolved.

Reply
0 Kudos
milwa04
Contributor
Contributor

I execute the vSphere client from a virtual machine.  I had problems with another application for several months.  I finally gave up trying to fix that application and reverted to a snapshot where I knew that application worked properly.  Restoring the "Users" folder was the ultimate cause of my problem with vSphere client.

After renaming the vpx folder to vpx.restored, the vSphere client recreated the vpx folder and started without problem.  I did not investigate much further but the vpx.restored folder contains a catalog and a PluginCache folder, and I am guessing that vSphere client did not know how to handle some change I made since the snapshot was created.

The path to the vpx folder on my virtual machine is:  C:\Users\<userid>\AppData\Local\VMware\

, where <userid> is my Windows user ID.

Reply
0 Kudos
ElmerD
Contributor
Contributor

Reply
0 Kudos
SIROVA
Contributor
Contributor

Hi,

Uninstall Vmware Data Recovery Plugin.

Reply
0 Kudos
guidol70
Contributor
Contributor

In my case, I had the same error with the text at the end of this entry in the logs. However, the cause revealed by procmon.exe was that c:\windows\syswow64\msvcr71.dll could not be overwritten (Write File). Seems reasonable, but that seems to be a standard corrective action by the VMWare code when it can't read msvcr71.dll. Somehow the local users had no read access to the file msvcr71.dll. After giving them read access, a non-admin user can connect to a central vmware cluster.

[        :startup :W: 1] 2015-03-02 21:33:33.398  Log for vSphere Client Launcher, pid=16256, version=5.1.0, build=build-1064113, option=release

[        :Error   :W: 1] 2015-03-02 21:33:33.436  System.UnauthorizedAccessException: Attempted to perform an unauthorized operation.

   at Microsoft.Win32.RegistryKey.Win32Error(Int32 errorCode, String str)

   at Microsoft.Win32.RegistryKey.SetValue(String name, Object value, RegistryValueKind valueKind)

   at Microsoft.Win32.RegistryKey.SetValue(String name, Object value)

   at VpxClient.Program.RegisterClientMimeExtension()

[        :QuickInf:W: 6] 2015-03-02 21:33:38.656  Set the dll search path to C:\Program Files (x86)\VMware\Infrastructure\Virtual Infrastructure Client\5.1

[        :QuickInf:W: 6] 2015-03-02 21:33:38.800  Load Shared DLLs: C:\Program Files (x86)\VMware\Infrastructure\Virtual Infrastructure Client\5.1

[        :startup :W: 6] 2015-03-02 21:33:39.349  Log for vSphere Client, pid=16256, version=5.1.0, build=build-1064113, option=release, user=root, url = https://ws156/sdk

[        :ShowExcp:W: 6] 2015-03-02 21:33:40.148  Error: Could not load file or assembly 'VpxClient.SSPI, Version=2.0.14.0, Culture=neutral, PublicKeyToken=9f0928b6ea506bde' or one of its dependencies. Access is denied.

System.IO.FileLoadException: Could not load file or assembly 'VpxClient.SSPI, Version=2.0.14.0, Culture=neutral, PublicKeyToken=9f0928b6ea506bde' or one of its dependencies. Access is denied.

   at VmomiSupport.ServiceManager.NewLoginSpec()

   at VMware.Vim.Client.VimClient.GetAnonymousLoginSpec(Dictionary`2 specMap)

   at VpxClient.UI.InitializeVimClient(Dictionary`2 specMap, String[] arguments)

   at VpxClient.UI.StartUpIfNotMultiVcSecure(Dictionary`2 specMap, SecureString password, String[] arguments, LoginEventHandler handler, String dllPath, List`1 listOfVcUrls)

System.UnauthorizedAccessException: Access is denied. (Exception from HRESULT: 0x80070005 (E_ACCESSDENIED))

   --- End of inner exception stack trace ---

Guido Leenders Invantive B.V. http://www.invantive.com
Reply
0 Kudos
daniextremo
Contributor
Contributor

Hello,

The fix http://hasstoppedworking.com/fix-clr20r3-event-issues/ . I don't know why, but my .Net Framework 2 perhaps is corrupt and some apps doesn't work fine.

In my case for vpxClient,

    - Place to dir C:\Program Files (x86)\VMware\Infrastructure\Virtual Infrastructure Client\Launcher (windows 7 Ultimate x64)

    - Edit file VpxClient.exe.config and add :

          <startup useLegacyV2RuntimeActivationPolicy="true">

              <supportedRuntime version="v4.0"/>

          </startup>

                    

Regards

ksamuel79
Contributor
Contributor

Kudos to you...Take a bow sir. Created ID here just to say you thanks

Since many days I was looking for solution of this problem...your solution worked for me.

Thanks once again.

Reply
0 Kudos
trunolimit
Enthusiast
Enthusiast

I'm on windows 10 latest build and was having this issue. the

<startup useLegacyV2RuntimeActivationPolicy="true">

              <supportedRuntime version="v4.0"/>

          </startup>

totally worked.

Reply
0 Kudos
bc90021
Contributor
Contributor

For me in Windows 10, I resolved this by right-clicking and using "Run as Administrator".

Reply
0 Kudos
jagdish_rana
Enthusiast
Enthusiast

Hi There,

Do you have local admin access on this system?

Please advise.

Thanks

Reply
0 Kudos
cbrandlehner
Contributor
Contributor

I can confirm, the VpxClient.exe.config edit fixes the problem.

Note that the xml statement has to be inserted before the </config> statement. Do not place it as the last statement in the file.

Reply
0 Kudos
SanderGNL
Contributor
Contributor

I had to choose 'run as administrator' on Windows 7. This solved the problem.

Reply
0 Kudos
bschonec
Contributor
Contributor

I was missing Tahoma fonts.  I copied Tahoma.ttf from another Windows 7 machine and installed the font on the laptop that was crashing.  All fixed. 

Check out the latest log file in C:\Users\<your user name>\AppData\Local\VMware\vpx.  Mine indicated:

System.ArgumentException: Font 'Tahoma' does not support style 'Regular'.

...

   at System.Drawing.Font..ctor(SerializationInfo info, StreamingContext context)

   --- End of inner exception stack trace ---

Sure enough, I was missing the Tahoma font.

Reply
0 Kudos