MaxPI
Contributor
Contributor

Vmware 5, One datastore become inactive (unmounted)

Jump to solution

Hello!

We use Vmware ESXi 5.0.0,1918656 and Hitachi AMS2100 fot datastores.

On 18.06.2018  one Datastore become Inactive (unmounted).

I found some problems with disk on AMS2100. After replacing failed hard disk, errors gone, and the status of raid and LUN become normal.

003_1.jpg

But in Vmware datastore still inactive. When i try to maunt, an error occurs.

007.jpg

Device status for this LUN is mounted

004.jpg

005.jpg

Add logs from ams and esxi

1 Solution

Accepted Solutions
Jitu211003
Hot Shot
Hot Shot

Hi,

I faced the same issue wherein storage went down unexpectedly and when it came online, 2 of 3 LUNs became inactive.

What we tried

Rescan

serivce restart on host

we rebooted the host.

and finally took a graceful reboot of the storage controller one by one which fixed this issue.

I had ESXi 5.0 with HP MSA storage DAS box.

Thanks

Vmwarediary.com/vmwarediary.in

View solution in original post

8 Replies
RickVerstegen
Expert
Expert

When you make changes in your SAN configuration, you might need to rescan your storage. Did you perform a rescan on your storage/storage adapters?

If this is not helping you probably need to perform the steps mentioned in the KB article. (VMware Knowledge Base ) It describes one of the symptoms that is applicable to you, "An ESXi 5.x host cannot mount the storage after the LUN is online again".

Rick

Blog: https://rickverstegen84.wordpress.com/ Twitter: https://twitter.com/verstegenrick
MaxPI
Contributor
Contributor

Thanks for the answer. Yes, i perform a rescan on storage/storage adapters. Also i've already tried to do the tips described in this KB article. They did not help. I also tried to remove this LUN from AMS Host Groups, then rescan storages/adapters in esxi.  After rescan datastore and device disappeared from lists. After that i remove from Inventory all VM whith unknown status  on every ESXi hots and perform Restart Management Agent on all esxi hosts. Then add LUN to Host Groups, rescan storage/storage adapters and datastore appeared, but stll inactive with same error.

0 Kudos
Jitu211003
Hot Shot
Hot Shot

Hi,

I faced the same issue wherein storage went down unexpectedly and when it came online, 2 of 3 LUNs became inactive.

What we tried

Rescan

serivce restart on host

we rebooted the host.

and finally took a graceful reboot of the storage controller one by one which fixed this issue.

I had ESXi 5.0 with HP MSA storage DAS box.

Thanks

Vmwarediary.com/vmwarediary.in

View solution in original post

continuum
Immortal
Immortal

Hi Maxim
please try if you can run this command via putty:
dd if=/dev/disks/naa.60060e80104d9b9004f348c100000015:1 of=/vmfs/volume/DATASTORE/maxim.1536 bs=1M count=1536
(replace DATASTORE with the name of one of your other datastores)

This command should create a file of 1536 MB in the datastore you specified.
If this works please download maxim.1536 , compress it and provide a download link.
If it fails - dd will display an error message - please post the message in your next reply.
Ulli

Do you need support with a recovery problem ? - call me via skype "sanbarrow"
MaxPI
Contributor
Contributor

Hi, continuum.

Thanks for reply.

I compress file with 7z1805. Link  maxim.7z - Google Drive

0 Kudos
MaxPI
Contributor
Contributor

Hi, Jitu211003!

Thanks for advices. I will try to reboot storage controller tomorrow.  I hope this helps

0 Kudos
continuum
Immortal
Immortal

Hi Maxim

your VMs are still there : I found 22 VMs if I counted right.
If you dont find a way to mount the volume again - call me via skype .
I think I can assist with extracting your data.
Ulli
skype:sanbarrow

Do you need support with a recovery problem ? - call me via skype "sanbarrow"
MaxPI
Contributor
Contributor

Hi continuum.

Thanks for help. Reboot of Storage System and Brocade SAN Switch Module worked for me.

0 Kudos