MrSiddiqui
Enthusiast
Enthusiast

Virtual machine Virtual WWNs not visible in the FC Fabric

Hi Friends,

Need some help as i'm trying to map FC LUNs directly to the Virtual Machines for this i have enabled NPIV in EDIT SETTINGS of the VM and there are WWNs\WWPNs assigned to VM.

Now these WWNs are not shown in the FC fabric hence i can not zone it with the SAN and present a LUN..

The only time these WWNs are visible for brief period of time is when i attached an RDM to the VM and after some time they are again gone.

For ref please see attached diagram..!

Details:

=====

1: B1/B2 brocade 6505(FOS 7.2.0a) IO Modules in ACCESS GATEWAY MODE.

2: ToR01/ToR02 Brocade 6505 (FOS 7.2.0a) in NATIVE SWITCH MODE.

3: NPIV is enabled end to end.

4: Qlogic 2662 16Gig FC HBA in blade servers. qlnativefc driver loaded in ESXi 5.5.

5: ESXi and vcenter version is 5.5.0.

6: EMC VMAX 10k FC SAN

7: Dell 1000e bladechassis

Please help and guide..

Thanks

Tags (4)
0 Kudos
5 Replies

its an old article but maybe helps you

NPIV: N-Port ID Virtualization | VMware vSphere Blog - VMware Blogs

kind regards Vervoort Jurgen VCP6-DCV, VCP-cloud http://www.vdssystems.be
0 Kudos
MrSiddiqui
Enthusiast
Enthusiast

Hi vervoort,

Thanks for the article i have gone through it and tried everything as explained but still VMs WWN is not showing in the fabric..

The only time they are visible for brief period of time is when i add an RDM to VM.

Best Regards

0 Kudos
kcgwchen
Contributor
Contributor

Dear Sir

I encoumter the same problem as you, Have you resolve your case?

I can only see the vWWN when VM restart. And it only last about 10 sec. then it disapeared.

Any comment on this?

KC

0 Kudos
Finikiez
Champion
Champion

First of all you need to have up-to-date driver for FC HBA on your host. Than you have to add VM's WWN into each zone on FC switch where your ESXi host is added.

0 Kudos
ameyd
Contributor
Contributor

0 Kudos