VMware Cloud Community
Hot Shot
Hot Shot

Virtual Machine loses network connectivity

Hi Guys,

I have a windows 2008 SP2 guest Virtual Machine running on ESX 4 U2, which when i storage vmotion loses network connectivity after the Svmtion has completed.

I have installed the VMXNET3 NIC with given it a static IP address.

when i perform a ipconfig in the guest it shows the NIC has a APIPA IP address and not the static IP address. I have tried everything i can think of such as:

  • remove and reinstall NIC

  • Remove VMware tools and reinstall

  • Reinstalled new VM with same issue

But still cant get this to talk over VMXNET3. I have susequently moved to the E1000 adapter, but was wondering if anyone else has seen this?



0 Kudos
1 Reply

Hey Dougie

We had the same problem with a couple of servers that were set up with vmxnet3. What worked for us as a fix is, before doing a svmotion, we shut down the vm, downloaded the vmx file. Took a copy of the original vmx file as a backup 🙂


ethernet1.addressType = "vpx" to

ethernet1.addressType = "static"

Plus edited following:

ethernet1.generatedAddressOffset = "10"

ethernet1.generatedAddress = "00:50:56:95:00:07"

replace with:

ethernet1.AddressOffset = "10"

ethernet1.Address = "00:50:56:95:00:07"

This seems to work for us now.

Why this happens is another question ...


0 Kudos