Contributor
Contributor

Virtual IP feature of Windows 2008 R2 does not work on ESX 4

Hi,

Windows Server 2008 r2 supports a virtual IP in terminal server sessions.

The virtual IP can either be attached to individual sessions or applications.

Together with the MS support we saw, that under identical configurations this feature does not work in the ESX, but works on real hardware and Hyper-v as well. Now MS denies any further support in this case.

We already configured a different type of network adapter - without success.

Please se the attachement for the details about the eventlog (just one message, which indicates the problem).

Did sombody of you make the same experience?

Some ideas how to get arround that?

Thanks a lot,

Rolf

0 Kudos
18 Replies
Contributor
Contributor

Hi,

oh yes we do.

4 specialist did work on this problem several days and no working result. After endless tests we are sure it is a problem with ESX and Windows 2008 R2 Server.

regards Stefan

0 Kudos
Expert
Expert

Enable Promiscuous Mode within the portgroup or vswitch

0 Kudos
Contributor
Contributor

Thank you for the reply. We tried this also and had no success.

Have you tried the setting with success?

regards Stefan

0 Kudos
Expert
Expert

sure it works fine. the same principle applies to CARP/VRRP.

If you have changes the security settings next thing to check is the load balancing method.

0 Kudos
Contributor
Contributor

There is no loadbalancing configured at the moment. We have tried it again and can't see a dhcp request on our dhcp server coming from the windows 2008 R2 server and no virtual ip is assigned to the remote session.

Whould you be so kind and give us some more information?

- which adapter you use for the vm

- which security settings you talking about?

- we have no failover for the adapter configured, but if, which settings are important?

thank you for your help

Stefan

0 Kudos
Expert
Expert

There are two settings that need to be changed for WNLB to be used.

1) Within the Port Group or vswitch change "forged mac" to "accept"

2) Within the vswitch change "notify switches" to NO

Go here for more info:

http://kb.vmware.com/selfservice/microsites/search.do?language=en_US&cmd=displayKC&externalId=1556

Or you can just use "multicast mode"

0 Kudos
Contributor
Contributor

Sorry for the delay, the problem is also present.

We have information from vmware that it is working with vmware V3.5U5 and can be reproduced at vmware 4.

It should be fixed at U3. The Vmware Bug Numbr is 547341.

So i'm not shure if you have an identical configuration running.

Cheers

0 Kudos
Contributor
Contributor

Is this problem solved? I have the same problem on ESXi4.0. If theres a solution it would be nice to know.

0 Kudos
Contributor
Contributor

Try uninstalling VMware Tools, reboot guest and then make a custom VMware Tools installation where you choose not to install the VMCI driver.

Message was edited by: datahalland

0 Kudos
Contributor
Contributor

deinstalled the vmci driver but doesn't change anything. even without vmware tools it doesnt change. i've done all the things mentioned above but virtual ip doesn't work. :-(((

0 Kudos
Contributor
Contributor

Ive done a native fresh install of W2K8 Server R2 on a Proliant Server. DHCP Server is configured on the same machine. The Virtual IP Feature works if the normal Network Adapter is chosen.

When configuring DHCP and RDP to use a Network on the "Local Loopback Adapter" it doesn't work anymore. Seems to me that MS has general problems with virtual adapters.

0 Kudos
Contributor
Contributor

Hi, we make a production probes and we found that when we unistall the vmware tools, work fine with two network adapters.

0 Kudos
Contributor
Contributor

Even redirecting a physical Network Card with PassThrough dosen`t solve the Problem. But as soon as i uninstall VMware Tools everything is working fine.

0 Kudos
Contributor
Contributor

Removing the VMXNET3 adapter and driver and installing a E1000 network adapter solves my problem. (a VMXNET2 Enhanced adapter did not work completely, no RDP connection possible)

The problem is with the VMXNET3 driver. I hope there will be a fix soon, because I now have to work with the slowest network adapter available on this virtual machine.

0 Kudos
Contributor
Contributor

Anyone found a resolution to this issue besides uninstalling VM Tools or using the E100 adapter?

0 Kudos
Enthusiast
Enthusiast

I resolved this by disabling the "VMware VMCI Bus Device" in Device Manager (under System devices) and uninstalling the VMCI driver by modifying the VMware Tools installation, disabling IPv6 by unchecking the box in the Local Area Connection properties and setting the DisabledComponents DWORD value to 0xFFFFFFFF under HKLM\CurrentControlSet\services\TCPIP6\Parameters in the registry, and adding the server's IPv4 info to its hosts file, i.e.:

127.0.0.1       localhost

127.0.0.1       server1
127.0.0.1       server1.domain.com
10.0.0.10       server1
10.0.0.10       server1.domain.com

I also made sure any IPv6 references in the hosts file, such as ::1, were commented out.

I am using the VMXNET3 driver and did not make any config changes to the vSwitches and my RDS servers are successfully assigning virtual IPs from DHCP to each session.

0 Kudos
Contributor
Contributor

tried everything, but it doesnt work for my environment.

I have an ESX4.0 Host:

->DHCP-Server@Win2008R2Enterprise

->RemoteDesktopHost@Win2008R2Standard

Ip-Virt. activated on E1000 connected to the same VSwitch as the DHCP Server, VMware Tools are deinstalled, IPv6 disabled

0 Kudos
Contributor
Contributor

Thanks, Marcj1

I was helped by the following:

1. add VMXNET3 adapter and remove E1000

2. uninstalling the VMCI driver by modifying the VMware Tools installation

3. disabling IPv6 by unchecking the box in the Local Area Connection properties

4. setting the DisabledComponents DWORD value to 0xFFFFFFFF under HKLM\CurrentControlSet\services\TCPIP6\Parameters in the registry

0 Kudos