milsimr
Contributor
Contributor

Very poor upload speed to RAID 5 volume

Jump to solution

Hello everybody!

Got a weird issue here. I have DELL PowerEdge R720 server for homelab purposes and currently I have installed ESXi 6.7 U3 ( DellEMC-ESXi-6.7U3-18828794-A16 ).

Server has two RAID volumes on PERC H710 Mini (512 MB); one RAID 0 consisting of 2x Samsung SSD 840 Pro (256 GB) and second RAID 5 volume with 6x Seagate IronWolf 4 TB drives (SATA; admitedly not the best choice of drives, but hey - I've got them for free, so ....).

Server has all latest firmwares installed and there are no errors in logs and everything seems to work fine. However there is this VERY annoying issue, that whenever I am trying to upload *.iso file / whatever else via web GUI or via WinSCP (SSH), I am getting ridiculous upload speeds (like drops from tens of MB/s to units of kB at most), WinSCP even drops out completely trying to reconnect to the server and proceed with file transfer. While when trying to access the same RAID 5 volume from VM, everything seems to be fine; even tried Crystal Disk Mark from Win VM and speeds looks within expected parameters from RAID 5 array consisting of 5400k rpm drives.

Any ideas what to look for or where the issue might be? Thank you in advance.

0 Kudos
1 Solution

Accepted Solutions
kastlr
Expert
Expert

Hi,

 

check your network.

While VM activities or Crystal Disk Mark perform SCSI IOs coping a remote file will start with network transfer to the remote host.

Maybe you configured inconsistent MTU sizes are one component reports dropped packets or similar.



Hope this helps a bit.
Greetings from Germany. (CET)

View solution in original post

3 Replies
kastlr
Expert
Expert

Hi,

 

check your network.

While VM activities or Crystal Disk Mark perform SCSI IOs coping a remote file will start with network transfer to the remote host.

Maybe you configured inconsistent MTU sizes are one component reports dropped packets or similar.



Hope this helps a bit.
Greetings from Germany. (CET)
milsimr
Contributor
Contributor

Hi!

Thank you for your suggestion. I remember enabling jumbo frames on my workstation network card settings and also on main switch as well; will try to enable this feature in ESXi settings, maybe that will solve the problem.

Will let you know in evening when I will have the chance to play with this.

Otherwise for enabling jumbo frames I did not touch any MTU settings anywhere.

0 Kudos
milsimr
Contributor
Contributor

Hi!

Thank you for mentioning MTU settings; seems like that setting MTU for 9000 has really helped. Write nor read speeds are not impressive (still unable to use whole 1 Gbps LAN network speeds), but at least upload does not drop to speeds measured in kB/s anymore - which is what I wanted.

Thank you.

0 Kudos