Highlighted
Contributor
Contributor

VNC client connect to esxi 6 console keeps drop

when connect VNC client to esxi 6 console, the connection keeps dropping once enter the password. Does any one know the reason? the same setting as esxi 5 for VNC client enabled option.

VMware KB: Using a VNC Client to connect to virtual machines

6 Replies
Highlighted
Contributor
Contributor

捕获.PNGunderstand?

0 Kudos
Highlighted
Contributor
Contributor

Hi

I've try with a friend setup the new version 6 and as same as my 5.5 when I try vnc, it don't work. We paste the info as the KB into the vmx file of a vm :

RemoteDisplay.vnc.enabled = TRUE

RemoteDisplay.vnc.port = 5900

RemoteDisplay.vnc.password = pass

Try also to add 2 display or run at auto, but still no logging possible.

Perhaps it's a firewall port of esxi.. We also try to use port already open but not used as 8080 , 8200 and 80 but don't work either.

The vm had vmtools and ip is seen on the run page summary. If you had more hint to help made this work..

Thanks

0 Kudos
Highlighted
Hot Shot
Hot Shot

Can you confirm that the firewall rule for GdbServer is enabled ?

Host, Configuration, Security Profile, Firewall properties, select gdbserver.

Common practice would be to restrict this to IP addresses of machines allowed to connect to the VNC port, but for test you could leave that as "Allow connections fro any IP address"

This should allow you to connect to the VNC ports.

Let me know how you get on.

R

0 Kudos
Highlighted
Contributor
Contributor

I can verify this.  However For my esxi6 system it only seems to happen with VMs with text consoles.  Windows and Unix with graphical consoles seems to work for me.

0 Kudos
Highlighted
Contributor
Contributor

This worked for me.  I enabled that gdbserver & then rebooted my ESXi 6.x host, and it finally worked.

Aaron

0 Kudos
Highlighted
Contributor
Contributor

I tried with these settings & it worked for me.

1. Power off the VM.

2 add the following lines to the vm vmx file.

RemoteDisplay.vnc.enabled = "true"   ---- commas are required !!

RemoteDisplay.vnc.port = "5900"

3. Add a firewall rule in the esxi OR disable the firewall [ esxcli network firewall unload ]

4 . power on VM

5. If VNC client is properly configured with proper settings and port details , it will connect to the VM.

Thanks

- if it helps , please consider marking it as helpful !!