parthmaniar
Enthusiast
Enthusiast

VMware vSphere Hypervisor 7.0 - Unable to add secondary uplink/use onboard NIC.

Jump to solution

Hi, this is my first time setting up ESXi hence please pardon me if I do not provide all the required details. I apologise beforehand.

I have a Dell Precision Workstation that is not part of the HCL. However, both of my NICs are certified as per the compatibility list. I am running VMware vSphere Hypervisor 7.0 free edition.

Here you can see both of the NICs being detected.

pastedImage_1.png

Onboard NIC - Ethernet Connection I219-LM. I am able to see this in NIC in the system list but I am unable to add this as an uplink

pastedImage_0.png

PCIe - Ethernet Server Adapter I210-T1. After installation, this NIC is where management interface starts automatically.

What am I doing wrong and How do I use both the NICs?

Thank you.

32 Replies
parthmaniar
Enthusiast
Enthusiast

Hi, Are you saying that I cannot use the onboard NIC at all?

0 Kudos
a_p_
Leadership
Leadership

I'm afraid that this is the case with this NIC. I just searched the Internet, but wasn't able to find a driver for it. Sorry.

André

0 Kudos
parthmaniar
Enthusiast
Enthusiast

Thank you very much for helping and I appreciate everyone's kind guidance.

So much for student loan. I should have checked before buying the hardware that I did. Smiley Sad

0 Kudos
abhilashhb
VMware Employee
VMware Employee

The model is listed on the compatibility guide - VMware Compatibility Guide - I/O Device Search

------------------------------------------------------------------------------------------------------------------------------------ If you find this or any other answer useful please mark the answer as correct or helpful. Abhilash B | Blog : http://vpirate.in | Twitter : @abhilashhb | LinkedIn : https://www.linkedin.com/in/abhilashhb/ |
0 Kudos
abhilashhb
VMware Employee
VMware Employee

Did you try injecting the VIB into the 6.7 ISO and install it?

------------------------------------------------------------------------------------------------------------------------------------ If you find this or any other answer useful please mark the answer as correct or helpful. Abhilash B | Blog : http://vpirate.in | Twitter : @abhilashhb | LinkedIn : https://www.linkedin.com/in/abhilashhb/ |
0 Kudos
parthmaniar
Enthusiast
Enthusiast

I actually couldn't find how to do it. I did install 6.7 patch 3.

Could you kindly guide me? I have the 6.7 ISO. How do I inject and where is the driver that I need to inject? I have installed PowerCLi. I need the link to the driver that you want me to try

0 Kudos
a_p_
Leadership
Leadership

There are different I219-LM models on the HCL, but unfortunately not the one with the mentioned DID.


André

0 Kudos
parthmaniar
Enthusiast
Enthusiast

Thank you very much to everyone who has helped me with this.

I wish you good health and safety. Smiley Happy

parthmaniar
Enthusiast
Enthusiast

Hello,

I see in this post https://www.virtuallyghetto.com/2020/08/enhancements-to-the-community-ne1000-vib-for-intel-nuc-10.ht...  that drivers for the NIC that I have are available, specifically:

8086:0d4c - Ethernet Connection (11) I219-LM:

pastedImage_1.png

While the post mentions building new images to patch drivers, I was wondering if there was another way without formatting the ESXi host as I don't have access to vSphere.

Can this be done via SSH?

esxcli software profile update -d /vmfs/volumes/vsanDatastore/ISO/ESXi-7.0b-IntelNUC.zip -p ESXi-7.0b-IntelNUC10

0 Kudos
parthmaniar
Enthusiast
Enthusiast

I am unable to edit the post. Here is the command I tried:

esxcli software vib install -d /vmfs/volumes/volunemae/Intel-NUC-ne1000_0.8.4-3vmw.670.0.0.8169922-offline_bundle-16654787.zip

I got the following output:

pastedImage_0.png

0 Kudos
parthmaniar
Enthusiast
Enthusiast

Download driver using this link: https://download3.vmware.com/software/vmw-tools/Intel-NUC-ne1000_0.8.4-3vmw.670.0.0.8169922-offline_...

It supports:

  • 8086:0d4e - Ethernet Connection (10) I219-LM
  • 8086:0d4f - Ethernet Connection (10) I219-V
  • 8086:0d4c - Ethernet Connection (11) I219-LM
  • 8086:0d4d - Ethernet Connection (11) I219-V
  • 8086:0d53 - Ethernet Connection (12) I219-LM
  • 8086:0d55 - Ethernet Connection (12) I219-V
  • 8086:15fb - Ethernet Connection (13) I219-LM
  • 8086:15fc - Ethernet Connection (13) I219-V
  • 8086:15f9 - Ethernet Connection (14) I219-LM
  • 8086:15fa - Ethernet Connection (14) I219-V
  • 8086:15f4 - Ethernet Connection (15) I219-LM
  • 8086:15f5 - Ethernet Connection (15) I219-V
  • 8086:1a1e - Ethernet Connection (16) I219-LM
  • 8086:1a1f - Ethernet Connection (16) I219-V
  • 8086:1a1c - Ethernet Connection (17) I219-LM
  • 8086:1a1d - Ethernet Connection (17) I219-V

Update using ESXi CLI:

esxcli software vib install -d "path of the zip uploaded to your datastore"

THANK YOU EVERYONE!

View solution in original post

ryantitus
Contributor
Contributor

Anyone has the file? Download link seems to be broken 😞

0 Kudos
jihwang
Contributor
Contributor
0 Kudos