AndrewOB
Contributor
Contributor

VMtools failing sporadically

HI,

I've just installed HP custom image of VMware 6.0 on HPE proliant ML 350.  There are 3 X windows server 2012 VM's, 1 X Oracle linux VM and 1 X VCSA appliance.  VMtools is installed for the 4 VM's and shows in the vsphere console as Running(Current).

When I try to take a snapshot of a particular VM (FPS1) it is unable to because VMtools is reported as not running.  At this point the status in the console changes to Not Running (Current) for that VM.  I can open the console for the VM, check the systray and the VMtools icon is there and if I click it I can open it and see version details etc.  Then the vsphere client will report VMtools status as Running (Current) again.

To troubleshoot I have removed and reinstalled vmtools in the following way

Reboot FPS1

Stop VMtools service

Uninstall VMtools

Reboot FPS1

Remove VMtools folders from windows

Mount VMtools in virtual CD drive

Open admin cmd prompt

Browse to CD and run Setup64.exe

At this point VMtools will be shown as Running (current) but I am still unable to take snapshots using quiescence.

Has anyone come up against this issue?

Tags (1)
0 Kudos
3 Replies
rharry
VMware Employee
VMware Employee

The usual reason for this is due to over commit, i.e. the tools heartbeat daemon doesn't get sufficient CPU cycles in the guest to respond.

You have quite a hefty workload configured. How many physical cores do have? How many vCPUs are configured for each guest?

0 Kudos
AndrewOB
Contributor
Contributor

The physical host has single Xeon 8 core processor with 16 logical cores.  Each VM is assigned a single vCPU.  the other 2 Windows VMs do not suffer from the same issue.

I can increase the vCPUs on this VM as a test.

Can you suggest any further troubleshooting tips?

0 Kudos
AndrewOB
Contributor
Contributor

OK, looks like you are correct.  I have increased the vCPU count on that VM to 4 and the issue has gone away even though the monitoring had shown that with the single vCPU the processor utilisation never rose above 25%.

I will continue to monitor this for a few days to see if it reoccurs with the new settings.

Thanks rharry.

0 Kudos