VMware Cloud Community
ds2015
Contributor
Contributor
Jump to solution

VMWare Tools logging ? No Log file created

Hello,

i have SuSE Linux with VMWare Tools.

I add in the /etc/vmware-tools/tools.conf

[logging]

log=true

log.file="/var/log/vmwaretools.log"

log.level=debug

But the file is not create or write in.

What did i wrong ?

Is this a Problem that the "free" VMWareTools was insalled before ?

I like to know why the Scripts:

/usr/sbin/pre-freezescript and /usr/sbin/postthaw-script

are not start if i run a snapshot

Thanks

Reply
0 Kudos
1 Solution

Accepted Solutions
MKguy
Virtuoso
Virtuoso
Jump to solution

You configuration in /etc/vmware-tools/tools.conf should look like this:

[logging]
log = true
vmtoolsd.level = debug
vmtoolsd.handler = file

vmtoolsd.data = /var/log/vmtoolsd.log


See this article:

Enabling debug logging for VMware Tools within a guest operating system

With these settings I can get the logging to work in a SuSe guest VM.

I like to know why the Scripts:

/usr/sbin/pre-freezescript and /usr/sbin/postthaw-script

are not start if i run a snapshot

For starters the file names should be:

/usr/sbin/pre-freeze-script

/usr/sbin/post-thaw-script

Also these files must be executable with permissions of 0755 and owner root. Make sure this is set on the script files.

Also you can check the VM's vmware.log file on the datastore which records VM-related messages from the ESXi host point of view.

-- http://alpacapowered.wordpress.com

View solution in original post

Reply
0 Kudos
6 Replies
Techie01
Hot Shot
Hot Shot
Jump to solution

After making the changes in the file, have you restarted the vmtoold service from the GOS

>>

  • /etc/vmware-tools/services.sh start
  • /etc/vmware-tools/services.sh stop
  • /etc/vmware-tools/services.sh restart

>>

Reply
0 Kudos
ds2015
Contributor
Contributor
Jump to solution

thanks, i forgot to write, i did the restart..... but no change

Reply
0 Kudos
suvrobhattachar
Enthusiast
Enthusiast
Jump to solution

are you still facing the problem ?

Reply
0 Kudos
ds2015
Contributor
Contributor
Jump to solution

yes, have still the problem

Reply
0 Kudos
MKguy
Virtuoso
Virtuoso
Jump to solution

You configuration in /etc/vmware-tools/tools.conf should look like this:

[logging]
log = true
vmtoolsd.level = debug
vmtoolsd.handler = file

vmtoolsd.data = /var/log/vmtoolsd.log


See this article:

Enabling debug logging for VMware Tools within a guest operating system

With these settings I can get the logging to work in a SuSe guest VM.

I like to know why the Scripts:

/usr/sbin/pre-freezescript and /usr/sbin/postthaw-script

are not start if i run a snapshot

For starters the file names should be:

/usr/sbin/pre-freeze-script

/usr/sbin/post-thaw-script

Also these files must be executable with permissions of 0755 and owner root. Make sure this is set on the script files.

Also you can check the VM's vmware.log file on the datastore which records VM-related messages from the ESXi host point of view.

-- http://alpacapowered.wordpress.com
Reply
0 Kudos
ds2015
Contributor
Contributor
Jump to solution

thanks, i have deinstalled the original vmtools

an reinstalled the openVMTools from SuSE

and with your config it works!

Reply
0 Kudos