jgiovann
Contributor
Contributor

VM won't boot into graphical mode after migration

Jump to solution

Hi, 

Not sure if this is the correct forum to post my question. Just looking for some guidance.

I have a Debian Linux 8 (32-bit) VM running on an ESXi host (ESXi v7.0.2) in full graphics mode. The host machine is a DELL XPS 8920 (4 CPUs x Intel(R) Core(TM) i7-7700 CPU @ 3.60GHz).

After I copy/migrate the VM to another host with the same ESXi version (7.0.2), the machine won't boot into full graphics mode. The target host machine is a DELL PowerEdge 7515 (16 CPUs x AMD EPYC 7282 16-Core Processor)

I've checked all settings between the source VM and target VM and they are identical.

I can't see any difference other than the new host machine may have backwards compatibility issues in supporting an older Linux operating system.

Labels (5)
0 Kudos
1 Solution

Accepted Solutions
jgiovann
Contributor
Contributor

I found the solution myself.

In this instance I had to manually enable 3D support in the Video card settings for the target VM on the new host. This was greyed even with the VM turned off.

  • Shutdown the target VM
  • Logged into the ESXI host (hosting the guest target VM)
  • Manually edited the corresponding vmx file to include the following entry:
    mks.enable3d = TRUE
  • Determined the VMid of the target VM
    vim-cmd vmsvc/getallvms
  • Relaoded the VM's configuration file (e.g. VMid = 14)
    vim-cmd vmsvc/reload 14
  • Powered on the VM

After these changes, the VM was able to boot into full graphics mode (Debian Linux 😎

View solution in original post

0 Kudos
2 Replies
jgiovann
Contributor
Contributor

I found the solution myself.

In this instance I had to manually enable 3D support in the Video card settings for the target VM on the new host. This was greyed even with the VM turned off.

  • Shutdown the target VM
  • Logged into the ESXI host (hosting the guest target VM)
  • Manually edited the corresponding vmx file to include the following entry:
    mks.enable3d = TRUE
  • Determined the VMid of the target VM
    vim-cmd vmsvc/getallvms
  • Relaoded the VM's configuration file (e.g. VMid = 14)
    vim-cmd vmsvc/reload 14
  • Powered on the VM

After these changes, the VM was able to boot into full graphics mode (Debian Linux 😎

0 Kudos
scott28tt
VMware Employee
VMware Employee

Your post needs moving to the correct area, so I have reported it to the moderators.

 


-------------------------------------------------------------------------------------------------------------------------------------------------------------

Although I am a VMware employee I contribute to VMware Communities voluntarily (ie. not in any official capacity)
VMware Training & Certification blog
0 Kudos