themind
Contributor
Contributor

VM Consoles are Black, and Timeouts browsing to ESXi hosts

I have three issues that may be related somehow, that are only happening on my computer:

-in the vSphere Client, while connected to the vCenter Server, when trying to "Open Console" or click the Console tab on ANY VM, the screen appears black, with no errors.

-in the vSphere Client, if I try to directly connect to an ESXi host (either one of the two I have), it times out and gives the errors "Call "ServiceInstance.RetrieveContent" for object "ServiceInstance" on Server "" failed." and "The request failed because the remote server took too long to respond.  The command timed out as the remote server is taking to long to respond."

-when trying to web browse to the IP address or hostname of either of my two ESXi hosts, I get the certificate error screen and press continue, and then nothing happens (no connection, timeout).  It does the same thing in IE and Firefox, no difference.

I can view VM's in the "Open Console" or the console tab, directly connect to the ESXI hosts through vSphere Client, and web browse to the ESXi hosts on any other computer.  The issue only happens on my computer.

I verified that DNS is correct, NTP is correct.  I've also:

- Ran sfc /scannow on my machine

- cleared temporary internet files

- flushed and re-registered DNS with ipconfig

- reset TCP/IP stack

- cleared SSL state

- reset Internet Explorer settings

- updated/reinstalled network drivers

- uninstalled and reinstalled the vSphere client

- tried stopping services one at a time and testing again

- rebooted in Safe Mode and tried connecting

- uninstalled any programs related to networking such as WireShark/winpcap/etc.

- tried logging on under another user profile and connecting, same issue

I'm running out of ideas.  Anyone have a suggestion?

0 Kudos
8 Replies
themind
Contributor
Contributor

I forgot to mention, I'm running vCenter and ESXi hosts all on 5.0 U1 with all patches.  vSphere Client is 5.0 U1 as well.

I also turned off my Windows Firewall, no change.

0 Kudos
MartinAmaro
Expert
Expert

Couple things

1.- Disable firewalls or allow 80,443,902

2.- Do a simple ping test to the server you are trying to connect (IP and hostname)

     - make sure you have no packet lost

3.- check network switch for network port collisions

If you find this or any other answer useful please consider awarding points by marking the answer correct or helpful.
0 Kudos
themind
Contributor
Contributor

As I stated, I disabled firewall, no help.

Ping test to both ESXi hosts works fine.

Why would there be port collisions for my computer only?

0 Kudos
MartinAmaro
Expert
Expert

some times switch ports go bad or you speed duplex is different than what is configured on the switch port. Unless you have some kind of routing issue...

have you tried capturing the network traffic during your session? WireShark can help you with this..

If you find this or any other answer useful please consider awarding points by marking the answer correct or helpful.
0 Kudos
themind
Contributor
Contributor

Ok, I haven't monitored the network traffic, only processes.  I'll look at it and let you know what I find.

0 Kudos
themind
Contributor
Contributor

I tried changing to a different switch for my cable, verified port status was OK (even on the previous switch), and I still get the same issue.

I don't see anything in particular in Wireshark that tells me where the problem is...although I'm not 100% sure I know where to look.  When I follow the session trying to connect to the ESXi host, it seems to do the same thing that IE does, attempt to connect and then just sit around without error.

Everything used to work fine on my PC.  I'm not sure when it stopped working, as the gap of time I went back in on my own machine was too great to realize a specific incident or change that could have caused it.

0 Kudos
themind
Contributor
Contributor

I fixed the issue.

Rather than manually going through network card settings on my computer, I used the TCPOptimzer from SpeedGuide to adjust my networking registry settings (one of which was MTU), and after a reboot, all works fine.

0 Kudos
MartinAmaro
Expert
Expert

Glad you fixed your issue.

If you find this or any other answer useful please consider awarding points by marking the answer correct or helpful.
0 Kudos