kegwell
Enthusiast
Enthusiast

VI Client Not Opening In Foreground

Ever since I've upgraded to vSphere 6 (and client) I'm having an issue with the VI Client opening in the foreground UNLESS I run with Administrator privileges.  When I simply left-click on the icon, I can see the process(es) start in task manager, but can't get the program to appear in the foreground.  Even when I do an ALT-TAB and scroll through open windows, it's not list there.  However, if I right-click the icon and 'run as administrator' the window pops up immediately.  In fact, ALL previous instances I tried to open without administrator privileges also pop up.  For example, if I left-clicked the icon 3 times I would have 3 processes running the background (no visible windows).  Then, if I right-click/Run As Administrator I will immediately get the window for ALL 3 windows/processes running the background, plus the new one I just opened.

I've uninstalled all version of the VI client on my system and re-installed.  Once with my standard credentials and once again running installer as administrator...same results with both methods.

Anyone else having this issue?

--Matt

0 Kudos
2 Replies
RichardBush
Hot Shot
Hot Shot

I know this isnt a fix, but a way to get the application to always run as administrator:

To mark an application to always run as an administrator, do the following:

1. On the Start menu, locate the program that you want to always run as an administrator.

2. Right-click the application’s shortcut, and then click Properties.

3. In the Properties dialog box, click the Compatibility tab.

4. Do one of the following:

  • To apply the setting to the currently logged-on user, select the Run This Program As An Administrator check box, and then click OK.
  • To apply the setting to all users on the computer and regardless of which shortcut is used to start the application, click Change Setting For All Users to display the Properties dialog box for the application’s .exe file, select the Run This Program As An Administrator check box, and then click OK twice.

Could be a UAC issue ? What OS is the effected machine running ? Is your account an admin on that machine ?

kegwell
Enthusiast
Enthusiast

Thanks for the response.  Yes, this has been my workaround.  However, this a nuisance since I get the UAC pop-up each time I open the client...and unfortunately our security policies force UAC (grrrr)... 

0 Kudos