rgar120
Contributor
Contributor

Uploading VMs thru SSH/WinSCP going very slow

Hi,

I'm having an issue with uploading anything to our ESXi server, and in the title I said SSH/WinSCP but it's really anything. We first attempted to copy a Guest from our old ESXi machine yesterday using the migration tool, but it was going to take 22 hours. We let it run, and it failed last night about 9. So today we decided to try SSH with WinSCP. It is only copying at about 120kbps over a gigabit connection.

Anyone know what may be causing this? I followed the security hardening guidelines, so I am wondering if it was something in the proxy.xml file that may be causing this, as that was really the only thing changed that would alter network performance.

0 Kudos
2 Replies
rgar120
Contributor
Contributor

Scratch that, we got it. I didn't change the NIC properties from 100MB/Full Duplex to Auto-Negotiate.

0 Kudos
wila
Leadership
Leadership

Hi,

If you want speed when using WinSCP it is probably also a good idea to change the encryption from the default AES to Blowfish.

It normally will speed things up considerably. You might also want to try the free FastSCP from Veeam software.

Hope this helps,



--
Wil
_____________________________________________________
VI-Toolkit & scripts wiki at http://www.vi-toolkit.com

Contributing author at blog www.planetvm.net

Twitter: @wilva

| Author of Vimalin. The virtual machine Backup app for VMware Fusion, VMware Workstation and Player |
| More info at vimalin.com | Twitter @wilva