vGreg
Enthusiast
Enthusiast

Upgrade from ESX 4.0 to ESXi 4.1...???

I just started at a new job and they want me to upgrade all of their ESX 4.0 hosts to ESXi 4.1.... what is the process?  Is it just a bunch of fresh installs?  Are they required to buy licensing for ESXi 4.1?  Can someone point me in the right direction on this??

Thanks,

Greg

Mark this reply helpful if in fact it was... Greg W. Stuart Network+, Security+, VCP4/5 blog: http://vdestination.com http://twitter.com/vDestination
Tags (2)
0 Kudos
3 Replies
Dave_Mishchenko
Immortal
Immortal

Are these standalone hosts or connected to vCenter?  Let's say you have vCenter and your ESX hosts in a cluster.

1)  Upgrade vCenter to 4.1 (I would go to Update 1).

2) Migrate your VMs off of one host and take it offline.

3) Restage the host with ESXi, configure it and rejoin the cluster (you can run a mixed cluster with no issues).

4) Repeat the process until all the hosts are running ESXi.

If your licensing is OK for vSphere 4.1 then you won't have a problem with ESXi.  With vSphere licensing you can install ESX or ESXi.

The ESXi book in the 2nd link below deals with migrating from ESX to ESXi and you can get it as an ebook (see the first link).

Dave
VMware Communities User Moderator

Free ESXi Essentials training / eBook offer

Now available - VMware ESXi: Planning, Implementation, and Security

Also available - vSphere Quick Start Guide

vGreg
Enthusiast
Enthusiast

Dave,

This is a very helpful answer, my only question is, if my current hosts (yes they are in vCenter) are all ESX 4.0, how do I get to ESXi 4.1?  I feel like that would require licensing... maybe not?  I'm sure you know.

-Greg

Mark this reply helpful if in fact it was... Greg W. Stuart Network+, Security+, VCP4/5 blog: http://vdestination.com http://twitter.com/vDestination
0 Kudos
Dave_Mishchenko
Immortal
Immortal

If their Subscription and Support agreement was current when 4.1 was released then they'll be OK for licensing.  A quick way to check is to login with their account and see if you can download 4.1.  If you can't then SnS was not kept up to date.

0 Kudos