VMware Cloud Community

Update to ESXi 7.0U2d broke wget?

Updated some hosts to ESXi 7.0U2d in a lab environment the other day. Before that was on U1d. Using wget as part of a crontab to ping a health check URL every minute. Before update it worked flawlessly. After update, health check shows servers down. Logged into one via SSH and manually ran wget with the health check URL and get the following output.

Connecting to hc-ping.com (
wget: error getting response: Cannot assign requested address

 Same output whether httpclient is allowed for outgoing firewall or not. The box definitely has internet as it resolves the domain as you can see and pinging google.com works. I also tried wget with another URL (wget github.com) and I get:

Connecting to github.com (
Connecting to github.com (
wget: error getting response

Anyone else experiencing this behavior with wget not working? Other than updating to 7.0U2d, nothing else was changed so not sure why such a simple command would suddenly stop working. Thought originally maybe because httpclient was not allowed in outgoing firewall after a reboot? But then I opened it and doesn't seem to make a difference.

0 Kudos
0 Replies