mhauck
Contributor
Contributor

Update Compliance = Missing

Sorry for the cross post. I originally posted this in the Update Manager section, but didn't get any hits...

We have 12 identical H/P blades divided into two clusters.

We have two Update Manager baselines for these clusters. One contains the VMware specific updates and the other contains the H/P updates.

I staged and remediated the first cluster and all updates were installed and the hosts show as compliant.

The second cluster installed all VMware updates but did not install six of the H/P updates;

34791_34791.pngpastedImage_1.png

In case it matters, the VMware updates included 5.0 update 3.

The staging task and the remediation task show as completing successfully.

I have tried this multiple times on one of the hosts. Manually put the host into maint mode. Rebooted the host.

I ran "esxcli software vib list" on one host in each cluster (assuming that is the way to determine what H/P updates have been installed) and it shows the same information for both;

34792_34792.pngpastedImage_4.png

Not sure where to go to find out why one cluster is showing as compliant and the other is not.

Any help would be appreciated.

0 Kudos
2 Replies
247RACK
Contributor
Contributor

By definition  :

Missing compliance state indicates that the update is applicable to the target object, but not yet installed. You must perform a remediation on the target object with this update, so that the update becomes compliant


Are those hosts in question attached to a baseline that contain the HP updates?

I would suggest you review the Update Manager log file:


"
Your drive letter" :\Documents and Settings\All Users\Application Data\VMware\VMware Update Manager\Logs\vmware-vum-server-log4cpp.log

VMware Partner - Cloud Hosting Simplified www.247RACK.com VMware HA Cloud Hosting & Dedicated Enterprise servers Tier 3 Datacenters in NY, NJ, MD, VA, CA and Toronto 100% SLA Skype: HanoonEverywhere
0 Kudos
mhauck
Contributor
Contributor

Thank you for your input.

I received a reply to my original post in the Update Manager forum who was having the same issue.

He ended up removing all H/P updates from the baseline except for the most recently released. Once he remediated using only those two updates the hosts showed as being compliant.

Not sure why the hosts wouldn't install the most recent updates when mixed with the others, or why my other identically configured hosts in a different cluster had no problems with these same updates, but the issue is resolved.

0 Kudos