PeteNA
Contributor
Contributor

Update 2 for 5.0 doesn't stick

Greets -

I am attempting to upgrade our ESXi 5.0 to Update 2. I have tried essentially all upgrade options.

1) tried with VUM it would show it is compliant but the build number still displays 1117897.

2) tried booting with the .iso  (VMvisor-Installer-5.0.0.update02-914586.x86_64.iso) I would select the Upgrade option it would go through its upgrade process prompting me to reboot and comes up with "VMware ESXi 5.0.0 (VMKernel Release Build 1117897) versus 914586.

Any thoughts.. ? Hints or tips?

thanks

0 Kudos
10 Replies
SureshKumarMuth
Commander
Commander

You are already running on ESXi 5.0 U2 after that few patches have been released and the latest one is 1117897 along with the ESXi 5.0 U2 and other patch which was recently released.

So no worries...continue with that...

simple analysis from my end just compare the build number 1117897 > 914586

Regards, Suresh https://vconnectit.wordpress.com/
0 Kudos
admin
Immortal
Immortal

VMware ESX hosts are patched according to a model where each patch bundle only updates a few components of the ESX installation at a time. Not all components of the installation are upgraded

As a result, the ESX installation can have different components at different build numbers, depending upon which patch bundles have been applied.

If you wanna dig deep into the details of the build on your host.

check this KB.

VMware KB: Determining detailed build number information for VMware hosts

0 Kudos
PeteNA
Contributor
Contributor

Well ok that is odd however I thought one of the features (that I was highly interested in) is that when you move a svmotion a VM the name (folder and under lying files would change to the new vm name) I do not see that happening.. Tried it hot and cold.

0 Kudos
SureshKumarMuth
Commander
Commander

storage vmotion generally does not change the VM name, it is just moving your VM files from one datastore to another... probably you are talking about cloning where we can specify new VM name I guess

Regards, Suresh https://vconnectit.wordpress.com/
0 Kudos
admin
Immortal
Immortal

Oh if your looking that feature, it actually not enable by default as soon as you upgrade.

To fully resolve this issue after updating the vCenter Server, add the provisioning.relocate.enableRename advanced parameter to vCenter Server and set its value to true:

Note: The default value for provisioning.relocate.enableRename is false.

  1. Log into the vSphere Client as an Administrator.
  2. Click Administration > vCenter Server Settings.
  3. Click Advanced Settings.
  4. Add this advanced parameter Key:

    provisioning.relocate.enableRename

  5. Set the value to:

    true

  6. Click OK.
  7. Restart the VMware VirtualCenter Server service for the changes to take effect. For more information, see Stopping, starting, or restarting vCenter services (1003895).

Check this KB for details VMware KB: vSphere 5.x Storage vMotion does not rename virtual machine files on completing migration...

0 Kudos

I think this blog answers your question Storage vMotion does not rename files?

Please consider marking this answer "correct" or "helpful" if you found it useful.
0 Kudos
PeteNA
Contributor
Contributor

0 Kudos
admin
Immortal
Immortal

Yes I agree, as per Duncan link it says so,  But as per the VMware KB: vSphere 5.x Storage vMotion does not rename virtual machine files on completing migration...its not enabled as default,

and check this post by Duncan  Storage vMotion does not rename files?. which was later than the original post

Thanks,

0 Kudos

Not according to this and the links within it..

http://www.yellow-bricks.com/2012/12/21/renaming-virtual-machine-files-using-svmotion-back/

If you check the link Storage vMotion does not rename files? he has clearly mentioned in the first line of the blog that "A while back I posted that 5.0 U2 re-introduced the renaming behavior for VM file names"

Thanks

Please consider marking this answer "correct" or "helpful" if you found it useful.
0 Kudos
PeteNA
Contributor
Contributor

Thanks.. This did the trick

0 Kudos