3JL
Contributor
Contributor

Updat error: Could not find a trusted signer when updating from ESXi build 15820472

Jump to solution

Dear all,

I am trying to update my ESXi install from the command line. But fail with the following error:

Failed to setup upgrade using esx-update VIB: ('VMware_bootbank_esx-update_6.7.0-3.116.16713306', 'Could not find a trusted signer: certificate is not yet valid')

Command used:

esxcli software profile update -p ESXi-6.7.0-20200804001-standard -d https://hostupdate.vmware.com/software/VUM/PRODUCTION/main/vmw-depot-index.xml

From this article I understand that I should update gradually: VMware Knowledge Base

However, I have tried virtually any built, without success...

Also, offline update does not work either:

esxcli software profile update -d /vmfs/volumes/datastore1/VMware-ESXi-7.0.0-16324942-depot.zip -p ESXi-7.0.0-16324942-standard

I also tried this, without succes:

esxcli software acceptance set --level=CommunitySupported

Does anyone have a suggestion how to fix this?

Thanks! J

---

esxcli software profile get

(Updated) ESXi-6.7.0-20191204001-standard

   Name: (Updated) ESXi-6.7.0-20191204001-standard

   Vendor: VMware, Inc.

   Creation Time: 2016-01-03T20:53:59

   Modification Time: 2016-01-03T20:53:59

   Stateless Ready: True

   Description:

   

      2016-01-03T20:53:59.541116+00:00: The following VIBs are

      installed:

        elx-esx-libelxima.so  11.4.1184.2-3.89.15160138

        esx-update    6.7.0-3.89.15160138

        esx-base      6.7.0-3.89.15160138

        native-misc-drivers   6.7.0-3.89.15160138

        net-vmxnet3   1.1.3.0-3vmw.670.3.89.15160138

        vsan  6.7.0-3.89.14840357

        vmkusb        0.1-1vmw.670.3.89.15160138

        vsanhealth    6.7.0-3.89.14840358

      ----------

      2019-11-30T21:24:18.307612+00:00: The following VIBs are

      installed:

        nvme  1.2.2.28-1vmw.670.3.73.14320388

        iser  1.0.0.0-1vmw.670.1.28.10302608

        lsu-intel-vmd-plugin  1.0.0-2vmw.670.1.28.10302608

        vsanhealth    6.7.0-3.77.14914425

        brcmfcoe      11.4.1078.25-14vmw.670.3.73.14320388

        vmware-esx-esxcli-nvme-plugin 1.2.0.36-2.48.13006603

        ne1000        0.8.4-2vmw.670.2.48.13006603

        nvmxnet3      2.0.0.29-1vmw.670.1.28.10302608

        lsu-hp-hpsa-plugin    2.0.0-16vmw.670.1.28.10302608

        lsi-msgpt2    20.00.06.00-2vmw.670.3.73.14320388

        esx-base      6.7.0-3.77.15018017

        nmlx4-rdma    3.17.13.1-1vmw.670.2.48.13006603

        bnxtroce      20.6.101.0-20vmw.670.1.28.10302608

        mtip32xx-native       3.9.8-1vmw.670.1.28.10302608

        lsi-msgpt3    17.00.02.00-1vmw.670.3.73.14320388

        nfnic 4.0.0.29-0vmw.670.3.73.14320388

        vmkusb        0.1-1vmw.670.2.48.13006603

        nmlx4-core    3.17.13.1-1vmw.670.2.48.13006603

        ipmi-ipmi-si-drv      39.1-5vmw.670.1.28.10302608

        sfvmk 1.0.0.1003-6vmw.670.3.73.14320388

        igbn  0.1.1.0-5vmw.670.3.73.14320388

        nhpsa 2.0.22-3vmw.670.1.28.10302608

        ipmi-ipmi-devintf     39.1-5vmw.670.1.28.10302608

        tools-light   10.3.10.12406962-14141615

        misc-drivers  6.7.0-2.48.13006603

        esx-xserver   6.7.0-3.73.14320388

        cpu-microcode 6.7.0-3.77.15018017

        vsan  6.7.0-3.77.14914424

        ixgben        1.7.1.16-1vmw.670.3.73.14320388

        elx-esx-libelxima.so  11.4.1184.1-2.48.13006603

        lsi-msgpt35   09.00.00.00-5vmw.670.3.73.14320388

        lpfc  11.4.33.25-14vmw.670.3.73.14320388

        qlnativefc    3.1.8.0-5vmw.670.3.73.14320388

        lsu-lsi-lsi-msgpt3-plugin     1.0.0-9vmw.670.2.48.13006603

        vmkfcoe       1.0.0.1-1vmw.670.1.28.10302608

        ipmi-ipmi-msghandler  39.1-5vmw.670.1.28.10302608

        smartpqi      1.0.1.553-28vmw.670.3.73.14320388

        esx-ui        1.33.4-14093553

        native-misc-drivers   6.7.0-2.48.13006603

        elxnet        11.4.1097.0-5vmw.670.3.73.14320388

        lsi-mr3       7.708.07.00-3vmw.670.3.73.14320388

        lsu-smartpqi-plugin   1.0.0-3vmw.670.1.28.10302608

        net-vmxnet3   1.1.3.0-3vmw.670.2.48.13006603

        i40en 1.8.1.9-2vmw.670.3.73.14320388

        nmlx5-rdma    4.17.13.1-1vmw.670.2.48.13006603

        nenic 1.0.29.0-1vmw.670.3.73.14320388

        vmw-ahci      1.2.8-1vmw.670.3.73.14320388

        ntg3  4.1.3.2-1vmw.670.1.28.10302608

        nmlx4-en      3.17.13.1-1vmw.670.2.48.13006603

        qedentv       2.0.6.4-10vmw.670.1.28.10302608

        bnxtnet       20.6.101.7-24vmw.670.3.73.14320388

        lsu-lsi-lsi-mr3-plugin        1.0.0-13vmw.670.1.28.10302608

        esx-update    6.7.0-3.77.15018017

        lsu-lsi-drivers-plugin        1.0.0-1vmw.670.2.48.13006603

        nmlx5-core    4.17.13.1-1vmw.670.3.73.14320388

      ----------

      The general availability release of VMware ESXi Server 6.7.0

      brings whole new levels of virtualization performance to

      datacenters and enterprises.

Tags (1)
1 Solution

Accepted Solutions
Techie01
Hot Shot
Hot Shot

Something wrong with the system date

esxcli software profile get

(Updated) ESXi-6.7.0-20191204001-standard

   Name: (Updated) ESXi-6.7.0-20191204001-standard

   Vendor: VMware, Inc.

   Creation Time: 2016-01-03T20:53:59

   Modification Time: 2016-01-03T20:53:59

The creation date and modification date are pointing to 2016-01-03 .

The 67 Pathc01  VIBs are shown as installed on -- 2019-11-30T21:24:18

The latest 67 patch ( 15160138 ) vibs are shown as installed on -- 2016-01-03T20:53:59

That is not really possible. Please check date in machine . Not sure if correcting date will eventually solve or not.

View solution in original post

5 Replies
berndweyand
Expert
Expert

is date and time correct on your host ?

try with esxcli <command> --no-sig-check

Techie01
Hot Shot
Hot Shot

Something wrong with the system date

esxcli software profile get

(Updated) ESXi-6.7.0-20191204001-standard

   Name: (Updated) ESXi-6.7.0-20191204001-standard

   Vendor: VMware, Inc.

   Creation Time: 2016-01-03T20:53:59

   Modification Time: 2016-01-03T20:53:59

The creation date and modification date are pointing to 2016-01-03 .

The 67 Pathc01  VIBs are shown as installed on -- 2019-11-30T21:24:18

The latest 67 patch ( 15160138 ) vibs are shown as installed on -- 2016-01-03T20:53:59

That is not really possible. Please check date in machine . Not sure if correcting date will eventually solve or not.

View solution in original post

3JL
Contributor
Contributor

That did the trick!! Thanks!!! Smiley Happy

0 Kudos
mmccann
Contributor
Contributor

This was the fix I needed.  I had an older driver that would not install until I used this flag.  Thanks.

0 Kudos
wsasaramago
Contributor
Contributor

That was indeed what fixed it, however...

Please pay attention to your BIOS / BIOS boot settings / BIOS security settings:

When security boot is enabled, you will not be able to install "Community VIBs"  even with the --no-sig-check trick.

I am André, and after many years only getting help, I decided to share some as well. I hope I am up to it. Thank You.
0 Kudos