pauldexterocsl
Contributor
Contributor

Unable to remove software iscsi storage adapter

Jump to solution

Looked everywhere for this and keep being told to go into the properties, uncheck the 'Enabled' selection and reboot.  Problem is that the 'Enabled' box is greyed out so I am unable to clear.  Any ideas how I can remove the software iscsi adapter when it is greyed out?

Thanks in advance

0 Kudos
1 Solution

Accepted Solutions
pauldexterocsl
Contributor
Contributor

I worked around this by disabling the module: bnx2i

We could not find any other way of removing this from vmware.  I believe it would have seen this the first time we installed ESXi as the card personality in BIOS was set to iSCSI.

View solution in original post

0 Kudos
9 Replies

Try to disable the adapter via ESXCLI command-line:

iscsi software set

Then try to remove the adapter.

-------------------------------------------------------------------------------------
Davoud Teimouri - https://www.teimouri.net - Twitter: @davoud_teimouri Facebook: https://www.facebook.com/teimouri.net/
0 Kudos
vHaridas
Expert
Expert

Do you have any active iscsi connection/datastores connected?

are you checking Enabled checkbox under Properties --> Configure Button?

Thanks,

vHaridas

http://www.vprhcs.in/

Please consider awarding points for "Correct" or "Helpful" replies. Thanks....!!! https://vprhlabs.blogspot.in/
0 Kudos
pauldexterocsl
Contributor
Contributor

Thanks for the suggestion.  I have already tried this and it was not successful I'm afraid, the adapter remained and was still there after a reboot

0 Kudos
pauldexterocsl
Contributor
Contributor

I do not have any storage connected to this ESXi server yet and yes the 'Enabled' checkbox is under the Configure button.

0 Kudos
pauldexterocsl
Contributor
Contributor

Update to this issue:

Turns out that the iSCSI adapter is tied to the CNA card installed in the server.  You can set it's personality in the BIOS to either iSCSI or FCOE.  Seems like it is seeing both as the FCOE adapter is functioning as expected but it also sees the iSCSI part of it, even though we do not want to use it and we have disabled this in the BIOS.

The only work around I have managed to find is that by disabling the driver it uses this then removes the card on start up.  I ran this command to do it:

esxcfg-module -d bnx2i

Digging through the OS files in scratch you can see that when the server boots it sees the iSCSI part of these adapters and loads in the drivers.  This is what I need to stop ESX from doing, so I think this is potentially in the BIOS somewhere.  Interestingly we have an identical ESX server that is not exhibiting this behavior.

0 Kudos
vHaridas
Expert
Expert

Can you try esxcfg-swiscsi -d from esxi command line?

as per VMware docs, if you are using software iSCSI for boot then it will re-enable iscsi adapter after reboot.

Please consider awarding points for "Correct" or "Helpful" replies. Thanks....!!! https://vprhlabs.blogspot.in/
0 Kudos
pauldexterocsl
Contributor
Contributor

Thanks - I have disabled this and rebooted the server but unfortunately the adapter is still present

0 Kudos
pauldexterocsl
Contributor
Contributor

I worked around this by disabling the module: bnx2i

We could not find any other way of removing this from vmware.  I believe it would have seen this the first time we installed ESXi as the card personality in BIOS was set to iSCSI.

0 Kudos
vHaridas
Expert
Expert

glad you are able to figure it out. Smiley Happy

-

Haridas Vhadade

http://www.vprhcs.in/

Please consider awarding points for "Correct" or "Helpful" replies. Thanks....!!! https://vprhlabs.blogspot.in/
0 Kudos