Henrique_Cicuto
Enthusiast
Enthusiast

Unable to mount NFS 4.1 datastore on ESXi 6

Jump to solution

Good afternoon,

I´m running some tests and now I built a CentOS 6 with NFS 4.1 as a NAS.

Some lines from CentOS /var/log/messages:


rpc.statd[1623]: Version 1.2.3 starting

sm-notify[1624]: Version 1.2.3 starting

kernel: RPC: Registered named UNIX socket transport module.

kernel: RPC: Registered udp transport module.

kernel: RPC: Registered tcp transport module.

kernel: RPC: Registered tcp NFSv4.1 backchannel transport module.

kernel: Installing knfsd (copyright (C) 1996 okir@monad.swb.de).

rpc.mountd[1720]: Version 1.2.3 starting

kernel: NFSD: Using /var/lib/nfs/v4recovery as the NFSv4 state recovery directory

kernel: NFSD: starting 90-second grace period

If I mount it from a Linux box, it works just fine:

# mount.nfs4 <nfs_fqdn>:/ /media

# mount

....

<nfs_fqdn>:/ on /media type nfs4 (rw,addr=192.168.X.X,clientaddr=192.168.X.Y)

Now, if I try mounting it from an ESXi 6 host, I get the following message:


An error occurred during host configuration.

Operation failed, diagnostics report: Sysinfo error on operation returned status : Timeout. Please see the VMkernel log for detailed error information


Some lines from vmkernel.log:

NFS41: NFS41_VSIMountSet:402: Mount server: <server_hostname>, port: 2049, path: /nfs, label: NFSv4, security: 1 user: , options: <none>

StorageApdHandler: 982: APD Handle  Created with lock[StorageApd-0x430694551140]

WARNING: NFS41: NFS41ExidNFSProcess:2022: Server doesn't support the NFS 4.1 protocol

WARNING: NFS41: NFS41ExidNFSProcess:2022: Server doesn't support the NFS 4.1 protocol

WARNING: NFS41: NFS41FSWaitForCluster:3433: Failed to wait for the cluster to be located: Timeout

WARNING: NFS41: NFS41_FSMount:4412: NFS41FSDoMount failed: Timeout

StorageApdHandler: 1066: Freeing APD handle 0x430694551140

StorageApdHandler: 1150: APD Handle freed!

WARNING: NFS41: NFS41_VSIMountSet:410: NFS41_FSMount failed: Timeout

Has anyone ever configured a Linux box as a NFS v4.1 endpoint for vSphere before?

Thank you very much

0 Kudos
1 Solution

Accepted Solutions
Henrique_Cicuto
Enthusiast
Enthusiast

Well, the problem was exactly as described:

WARNING: NFS41: NFS41ExidNFSProcess:2022: Server doesn't support the NFS 4.1 protocol

WARNING: NFS41: NFS41ExidNFSProcess:2022: Server doesn't support the NFS 4.1 protocol


My Linux box´s kernel did not support NFS 4.1, only 4.0.

Solution was upgrading the distro.

Thanks for the attention.

View solution in original post

0 Kudos
1 Reply
Henrique_Cicuto
Enthusiast
Enthusiast

Well, the problem was exactly as described:

WARNING: NFS41: NFS41ExidNFSProcess:2022: Server doesn't support the NFS 4.1 protocol

WARNING: NFS41: NFS41ExidNFSProcess:2022: Server doesn't support the NFS 4.1 protocol


My Linux box´s kernel did not support NFS 4.1, only 4.0.

Solution was upgrading the distro.

Thanks for the attention.

0 Kudos