Highlighted
Enthusiast
Enthusiast

Unable to launch Remote Console on Linux

Jump to solution

I'm running openSUSE 42.2 and I am unable to get the Launch Remote Console action to work.

After some investigation it appears to be crashing immediately.  If try and run it manually via "/usr/bin/vmrc -H xxx" then it starts and asks for authentication and once provided closes.  Attached is the log file that is produced.

The error appears to be:

W115+ gVmomi:ERROR:bora/vim/lib/gvmomi/gvmomiSession.c:913:gvmomi_session_server_version_cb: assertion failed: (!session->priv->verifyCertErrorResponded)

Does anybody know of a workaround or fix to this?

0 Kudos
1 Solution

Accepted Solutions
Highlighted
Virtuoso
Virtuoso

It is likely a problem with the libcurl4 that caused the SSL problems such as VMware Workstation on OpenSUSE crashes upon trying to connect to ESXi server Re: Workstation 12.5.5 crashes immedeately when trying to connect to ESXi 5.5 server

Have a look at this Re: vmware workstation hostd (shared vms) not starting on fresh linux install to roll back the libcurl4 and see whether it fixes the VMRC problem.

View solution in original post

2 Replies
Highlighted
Virtuoso
Virtuoso

It is likely a problem with the libcurl4 that caused the SSL problems such as VMware Workstation on OpenSUSE crashes upon trying to connect to ESXi server Re: Workstation 12.5.5 crashes immedeately when trying to connect to ESXi 5.5 server

Have a look at this Re: vmware workstation hostd (shared vms) not starting on fresh linux install to roll back the libcurl4 and see whether it fixes the VMRC problem.

View solution in original post

Highlighted
Enthusiast
Enthusiast

Thanks.  I've applied kbrauna's fix by updating my ~/.profile to contain the line:

export VMWARE_USE_SHIPPED_LIBS=force

This allows the player to start without having to run out-dated libraries elsewhere.

0 Kudos