nedwilson1
Contributor
Contributor

Unable to install macOS guest on to ESXi 7.0U2A host, Apple hardware

VMware ESXi 7.0U2A is installed and running on a Rack Mount Mac Pro - 2019, MacPro7,1.

Prior to the installation of ESXi, this machine was upgraded to macOS Big Sur 11.3.1, to be sure that it had all the latest BIOS/firmware updates, etc.

I am aware that the 2019 Mac Pro is not on the VMware HCL. Since neither Apple nor VMware will support this configuration, this is a cry for help to the community, to see if anyone has actually gotten this to work. Every time I attempt to install the operating system, I observe the following behavior. Older versions of macOS ( < 10.14 ) will boot, but the progress bar will make it to half way, and it will hang, with the spinning beach ball of death.

vmware.log on the host contains the following messages:

HostSMCRead: Unable to read key "OSK0".
HostSMCRead: Unable to read key "OSK1".

Using Mojave or newer as the installer results in a kernel panic and a boot loop. The messages displayed in the log are:

HostSMCRead: Unable to read key "OSK0".
DarwinPanic: panic(cpu 0 caller 0xffffff7f8a012b5e): "DSMOS: SMC read error K0: 133"@/BuildRoot/Library/Caches/com.apple.xbs/Sources/DontStealMacOS/DontStealMacOS-27.200.2/Dont_Steal_MacOS.cpp:191

I feel I should restate here that I am attempting to install these macOS guests on Apple-branded hardware. This is *not* a hackintosh setup, nor have I installed the ESXi Unlocker. Doing so, sadly, would fix the issue, I found in earlier testing on a different machine, but I want to make sure that I'm in compliance with Both Apple's and VMware's EULAs. 

Has anyone out there actually gotten this to work? Is there a special combination of VMware ESXi version, or maybe it is configuration parameters in the .vmx file? I've tried basically every one of the following:

smc.present = "TRUE", "FALSE"
smc.version = "0"
smbios.reflectHost = "TRUE", "FALSE"

I've also tried messing around with setting serialNumber, hw.board-id, hw.model, etc., all to no avail.

Thanks in advance!

 

 

0 Kudos
0 Replies