meghas1234
Contributor
Contributor

Unable to do fresh installation on ESXi 4.1 on HP Blade server

Hi All,

We configured a new blade on our existing chasis. When I try to install ESXi 4.1 it stucks with following error

vmkctl.hostctlexception unable to load module /usr/lib/vmware/vmkmod/vmfs3 failure

Anyone can help!!!!

Server h/w model - HP ProLiant BL460c G7.

0 Kudos
9 Replies
Josh26
Virtuoso
Virtuoso

I got ESXi 4.1 installed on that same server so I know it can be done.

Usual options:

* Have you run HP's latest firmware updates for all components, iLO, BIOS, RAID?

* Are appropriate BIOS options setup in accordance with HP's recommendations for VMware?

* Are you installing from the HP ISO, or generic? Which ever one it is - try the other.

The error indicates something about the storage it doesn't like. What sort of storage does your blade have (ignoring any iSCSI that's not yet connected)

Edit: PS Any reason not to try version 5.x?

0 Kudos
meghas1234
Contributor
Contributor

Hi Josh,

We did install it on other servers but not working for this one only.

Yes, all firmwares are updated. It doesn't has aby iscsi attached to it.

* Are appropriate BIOS options setup in accordance with HP's recommendations for VMware?

How to confirm this?

* Are you installing from the HP ISO, or generic? Which ever one it is - try the other.

I am using the same setup which was used earlier for other server. Not tried HP. from where will i get that?

*PS Any reason not to try version 5.x?

All of our servers are running on esxi 4.1 only but we will migrate to 5.x very soon. But till the time all servers should be in same path as per company policy.

0 Kudos
Josh26
Virtuoso
Virtuoso

Hi,

How to confirm this?

There is an HP best practices guide but I can never find it when I want it. In the meantime, refer here:

http://communities.vmware.com/message/1577847

All of our servers are running on esxi 4.1 only but we will migrate to 5.x very soon. But till the time all servers should be in same path as per company policy.

Totally fair reason.

Does the server have local disks, or a USB drive or SD card for the install?

If it's USB or SD card, I suspect they may be faulty.

If it's disks, try to delete and recreate the RAID array.

0 Kudos
meghas1234
Contributor
Contributor

Hi josh,

Does the server have local disks, or a USB drive or SD card for the install?

It doesn't have any local disk. it just has the default chip for storing data. But not sure what do we call it. prob the SD card.

0 Kudos
meghas1234
Contributor
Contributor

Just to add on, i downloaded new iso from vmware. After accespting the licence aggreement, after installation of some files/drivers, it gives below error:

vmfs module failed to load. possible reasons might be, no network adapters conencted to the systm or a suitable driver could not be located. A third partu driver may be required. Ensure that there is at least one network adapter physically connected to the system before attempting installation.

0 Kudos
Josh26
Virtuoso
Virtuoso

meghas1234 wrote:

Hi josh,

It doesn't have any local disk. it just has the default chip for storing data. But not sure what do we call it. prob the SD card.

This would be an SD card.

I would suspect it is faulty - your server is failing when attempting to read it.

You should be able to swap the card with that of another server and confirm it.

0 Kudos
a_p_
Leadership
Leadership

... vmfs module failed to load...

This error message usually appears if the network adapters are not recognized. The UUID for the VMFS datastore is derived from the MAC address unless I'm mistaken.

To be able to setup and run ESXi 4.x on a G7 blade you'll need to use the HP installation package, which includes the required drivers. Please take a look at http://v-front.blogspot.de/p/hp-vmware-links.html which contains an excellent collection of HP related links (including the one to the HP customized ISO).


André

0 Kudos
meghas1234
Contributor
Contributor

okay.. I am also installing the setup from HP. lets see if it works.

Josh - The installatin starts and it download few drivers, but then when i accept the licence aggreement after that it gives error. So if SD card is faulty then why not it gives error in the begining. Just curious to know...

0 Kudos
meghas1234
Contributor
Contributor

HP installation worked..

Thanks everyone..

0 Kudos