m4biz
Enthusiast
Enthusiast

Unable to connect to NFS server.

Hi.

I'm trying to test Instant Restore feature on my Veeam Server connected to ESXi  7.0 u3 standalone host .

The Veeam feature don't works because it can't mount NSF datasore on ESXi host.

If I look at vmkernel.log on ESXi host I see this:

NFS: 172: NFS mount 192.168.1.43:/VeeamBackup_w10-eM failed: Unable to connect to NFS server.

Any idea?

Thanks in advance

Ing. Cosimo Mercuro http://cosimomercuro.wordpress.com/
Tags (3)
0 Kudos
4 Replies
khiregange
VMware Employee
VMware Employee

NFS: 172: NFS mount 192.168.1.43:/VeeamBackup_w10-eM failed: Unable to connect to NFS server.

Please check the below things >

If both read / write permission has been granted to the esxi host 

check if the host is able to reach the NFS target ip from both FQDN and IP 

Try mounting the NFS from IP instead of hostname

Check if there are any firewall blocking the connections to the NFS target IP

Check if the port 2049 is allowed

 

Blog - Vmwarehelp.com

0 Kudos
m4biz
Enthusiast
Enthusiast

Hi kiregange

Thanks for your reply.

Where must I check  "...if the port 2049 is allowed..." ?

On the ESXi host itself?

 

Ing. Cosimo Mercuro http://cosimomercuro.wordpress.com/
0 Kudos
khiregange
VMware Employee
VMware Employee

https://kb.vmware.com/s/article/1003967

Verify connectivity to the NFS server and ensure that it is accessible through the firewalls. For more information, see Cannot connect to NFS network share (1007352).

Run the netcat (nc) command to see if you can reach the NFS server nfsd TCP/UDP port (default 2049) on the storage array from the host:

# nc -z array-IP 2049

0 Kudos
m4biz
Enthusiast
Enthusiast

Hi khiregange  

I've tested connectivity on between Veeam Server and ESXi host on port 2049 and it fail.

uno.png

On the windows Veeam server all firewall are disabled.

No any other firewall is between the ESXi 's Magement network and Veeam Windows PC.

due.png

I don't know what can stop connection.

Any idea?

 

Ing. Cosimo Mercuro http://cosimomercuro.wordpress.com/
0 Kudos