cygus
Contributor
Contributor

Ubuntu 14.04 LTS network performance problem

Hi,

I have problem with Ubuntu 14.04 LTS and network performance (ESXi 5.5). After starting downloading file (http/scp etc.) transfer is ok but after about 2-3s. transfer is going down to 0. I checked everything with virtual eth adapters (e1000 and vxnet3) and with vmware tools (vmware-tools and open-vm-tools).

This problem exists with transfer file to Internet, when I transfer file inside our network everything is ok.


Any idea?

0 Kudos
15 Replies
weinstein5
Immortal
Immortal

Welcome to the Community - if the performance issue is only with transfers to the internet than the issue is probably with your connection to the Internet - what type of connection do you have? Does you provider do any throttling?

If you find this or any other answer useful please consider awarding points by marking the answer correct or helpful
0 Kudos
cygus
Contributor
Contributor

Hello Smiley Happy

This isn't internet provider problem, because on physical servers, openvz and vmware 5.1 servers everything is ok.

This problem is only on vmware 5.5 with ubuntu 14.04 as guest OS.

0 Kudos
weinstein5
Immortal
Immortal

So you have other VMs running on the 5.5 server with no issue? If you do than I would say the issue is with Ubuntu configuration -

and I assume VMware Tools are installed?

If you find this or any other answer useful please consider awarding points by marking the answer correct or helpful
0 Kudos
cygus
Contributor
Contributor

Yes, I have for example debian on vmware esxi 5.5 and everything is ok, so this is ubuntu problem - I know.

I checked everything with virtual eth adapters (e1000 and vxnet3) and with vmware tools (vmware-tools and open-vm-tools).

Maybe this is problem with eth driver on ubuntu or something like this.

BR

0 Kudos
cygus
Contributor
Contributor

hmm on vmware 5.1 and ubuntu 14.04 everything is ok so this is probably problem with compatibility ubuntu 14.04 with vmware 5.5 or vmware 5.5 with ubuntu 14.04

Any idea?

0 Kudos
wila
Immortal
Immortal

Hi,

I checked everything with virtual eth adapters (e1000 and vxnet3) and with vmware tools (vmware-tools and open-vm-tools).

vmxnet3 should give good performance. The e1000 device isn't performing well from what I've understood, however using an e1000e should give you decent performance.

Eg. the following line in your vmx for the ethernet0 device

ethernet0.virtualDev = "e1000e"

--

Wil

| Author of Vimalin. The virtual machine Backup app for VMware Fusion, VMware Workstation and Player |
| More info at vimalin.com | Twitter @wilva
0 Kudos
cygus
Contributor
Contributor

Thx for reply.

After changing this par in vmx file ubuntu can't find ethernet adapter. What I should to do?

modprobe e1000e is hanging, ubuntu installer can't find ethernet adapter also.

BR

0 Kudos
wila
Immortal
Immortal

Hi,

Down here if I change it in 14.04 then nothing has to be changed, AFAIK the e1000e driver is in the default install. You shouldn't even have to run modprobe.

Maybe your edit had some problems?

Eg. if I list the loaded modules I now get:

$ sudo lsmod | grep e1000

e1000e                254433  0

ptp                    18933  1 e1000e

and as you see e1000e is loaded.

It also lists the device correctly here with a dmesg:

$ sudo dmesg | grep e1000

[    0.000000] BRK [0x01fe1000, 0x01fe1fff] PGTABLE

[    1.241122] e1000e: Intel(R) PRO/1000 Network Driver - 2.3.2-k

[    1.241124] e1000e: Copyright(c) 1999 - 2013 Intel Corporation.

[    1.241938] e1000e 0000:03:00.0: Interrupt Throttling Rate (ints/sec) set to dynamic conservative mode

[    1.242066] e1000e 0000:03:00.0: irq 73 for MSI/MSI-X

[    1.242118] e1000e 0000:03:00.0: irq 74 for MSI/MSI-X

[    1.242184] e1000e 0000:03:00.0: irq 75 for MSI/MSI-X

[    1.368980] e1000e 0000:03:00.0 eth0: registered PHC clock

[    1.368983] e1000e 0000:03:00.0 eth0: (PCI Express:2.5GT/s:Width x1) 00:0c:29:xx:xx:xx

[    1.368984] e1000e 0000:03:00.0 eth0: Intel(R) PRO/1000 Network Connection

[    1.369055] e1000e 0000:03:00.0 eth0: MAC: 3, PHY: 8, PBA No: 000000-000

[   14.868622] e1000e: eth0 NIC Link is Up 1000 Mbps Full Duplex, Flow Control

and lspci:

$ sudo lspci -v | grep e1000

    Kernel driver in use: e1000e

Attaching a vmware.log file when booting with the e1000e driver might help in order to see what is going on.

--

Wil

| Author of Vimalin. The virtual machine Backup app for VMware Fusion, VMware Workstation and Player |
| More info at vimalin.com | Twitter @wilva
0 Kudos
cygus
Contributor
Contributor

In vsphere client I don't have option to add e1000e vnic. I have only e1000 and vmxnet3.

My ubuntu uses e1000 driver:

lsmod | grep e1000

e1000                 133256  0

But I found something interesting.

Debian and ubuntu uses e1000 driver version 7.3.21-k8-NAPI but has different kernel version:

debian: 3.2.65-1+deb7u2

ubuntu: 3.16.0-30-generic

On debian everything is ok.

Maybe this is problem?

0 Kudos
cygus
Contributor
Contributor

I changed ubuntu kernel to debian kernel (3.2.65-1+deb7u2) and everything is ok, so this is ubuntu kernel problem.

Other solutions are welcome Smiley Wink

BR

0 Kudos
cygus
Contributor
Contributor

This same problem exists on debian with kernel 3.13 and 3.16.

0 Kudos
wila
Immortal
Immortal

Hello,

One thing I see now is that your Virtual Hardware has to be vHW version 8 or higher for the e1000e to be supported.

Maybe that is why the e1000e driver isn't working for you?

See also:

http://kb.vmware.com/1001805

PS: The option is not available in the vSphere Client for linux guests as is mentioned in the article. Suppose you could work around that by temporarily changing guest OS, then change NIC, then set gues OS version back to linux. Personally I just edit the .vmx file Smiley Wink

--

Wil

| Author of Vimalin. The virtual machine Backup app for VMware Fusion, VMware Workstation and Player |
| More info at vimalin.com | Twitter @wilva
0 Kudos
continuum
Immortal
Immortal

Watch out - the e1000e needs a PCI-express port and switching from e1000 to e1000e may fail because no additional express port can be allocated.
So if you make this change watch the vmware.log to see if allocating the pci-express slot was successful.


________________________________________________
Do you need support with a VMFS recovery problem ? - send a message via skype "sanbarrow"
I do not support Workstation 16 at this time ...

0 Kudos
cygus
Contributor
Contributor

Thanks for replies. The problem was linux kernel configuration with cisco asa cooperation (tcp selective acknowledgements).

0 Kudos
aseques
Contributor
Contributor

I had several issues with this, and did mostly the same as you (changing ethernets, etc..) at the end I located the issue in the vmware tools package that I had installed, (it might be that the propietary tools add some feature that's conflicting with my environment)

I replaced the vmware tools install with the open-vm-tools package (from the ubuntu repositories) and the issues where gone, I no longer have any issue with networking

0 Kudos