TechnikLS
Contributor
Contributor

Ubuntu 10.04 on ESX 4.0 very slow

Hi,

I run a Ubuntu 10.04 LTS Desktop System 4.0 on a ESX server.

Ubuntu system:

4x Intel Xenon 2.13GHz

3 GiB RAM

Kernel: 2.6.32-30-generic

Now the problem:

The server is slow after some time (hours). The interface works just slow and rebooting also takes very long.

What could be due to?

Thanks in advance.

Hallo,

ich betreibe ein Ubuntu 10.04 LTS Desktop System auf einem 4.0 ESX Server.

Ubuntu System:

4x Intel Xenon 2,13 GHz

3 GiB RAM

Kernel: 2.6.32-30-generic

Jetzt zum Problem:

Der Server wird nach einiger Zeit (Stunden) langsam. Das Interface funktioniert nur noch schleppend und das Neustarten dauert ebenfalls

sehr lang.

Woran kann das den liegen?

Danke schonmal. Smiley Happy

Tags (3)
0 Kudos
8 Replies
AndreTheGiant
Immortal
Immortal

I suggest to post in english.

Or in the proper VMUG area, in order to use your native language (Deutsch?).

Andre

Andre | http://about.me/amauro | http://vinfrastructure.it/ | @Andrea_Mauro
0 Kudos
BadriV
Contributor
Contributor

Did you install tools..? Are they compatibe with the interface that you are using..? Are you facing slowness in the network activities or in the system performance..? What does the ESX graph say..?

0 Kudos
TechnikLS
Contributor
Contributor

Hi,

the problems started just aufter the installation of the OS.

CPU using:  < 2%

Ram:            200MB  /3 GB

Swap:           0%

my GUI is GNOME 2.30.2

The network speed is ok. There is no traffic at all.

After restarting the system yesterday, it's running very well. I think in a few days it will be slow again.

0 Kudos
Jackobli
Virtuoso
Virtuoso

Did you really assign 4 vCPU to this Ubuntu guest?

How much physical CPU are running at your ESX host?

Do you use vSphere Client to connect to your guest or remote X or VNC?

How does it become slow? Mouse action? Menus?

I don't really like to use GUI Linux on ESX(i), they feel some kind of laggy. The vSpere client is not very well designed for running desktop os. Using other tools like VNC or RDP (for Windows) behaves better.

0 Kudos
vGreg
Enthusiast
Enthusiast

You may be experiencing a out of date VMware tools instance or haven't installed VMware tools at all.  Check to make sure it says "Ok" in your summary page of the Ubuntu VM next to the VMware Tools section.  It's an easy fix if that's the case.  What I would do is scrap Ubuntu 10.04 altogether and instead download 10.10 (maverick meerkat) it is way cooler anyways!

-Greg

vDestination.com

@vDestination

Mark this reply helpful if in fact it was... Greg W. Stuart Network+, Security+, VCP4/5 blog: http://vdestination.com http://twitter.com/vDestination
0 Kudos
blistovmhz
Contributor
Contributor

Same issue, but with more supporting data Smiley Wink.


I've been running Linux servers under ESX for years and have installed/managed >1000 vmware linux guests over the past few years.  I run into this problem occasionally and have not yet found a solution.

Currently:

VMware ESXi 4.1.0 with vSphere4 essentials license, running on a:

Dell PowerEdge T610

2x Intel Xeon E5520 @ 2.27GHz (4 core)

8181MB ECC RAM

5x 7200RPM SATA discs in a raid5 configuration.

I have ~20 guests running on this server.  19 are running Ubuntu 10.04 server or 10.10 server with VMwareTools installed from VMware ESXi (not the hacky OpenVMtools).

With all the machine powered on and settled into their jobs for a few days, my CPU usage averages 1.4GHz over the course of 24 hours (at a resolution of 10 samples per minute).  The RAM usage sits around 1.4GB active, 7GB consumed, and balloon is around 5GB.  I'm aware this is cutting it a little close, but the symptoms I experience are present even when RAM consumption is under 10% (1.6GB consumed and 1.2GB active).

The problem is that while machines are super responsive at boot and remain so for a few hours, after a period of relative inactivity (databases are still serving out data, but no users are actively logged into the machine) the server performance comes to a crawl.  Fetching a simple "hello world" in html from Apache takes >=10 seconds.  The second request is instantaneous.  Logging into a console (ssh), the machine takes 10 seconds to response to my first packet, presents me with a login prompt, I enter the username and wait for 10-15 seconds before prompted for the password, enter the password and wait 10-50 seconds before I'm finally logged in.  I use ssh -vvvvvvvvvvv to make sure the problem isn't an ssh problem.  The hang ups always occur while we're waiting for the server.  Once logged in, I issue a simple 'ls' on a directory with 1 file and wait for 5-10 seconds for a response.  Again, issuing the same command immediately, results in an immediate response.

This feels like swapping, but neither the VMguest nor the VMhost report any swapping.  I've even logged into the VMhost via ssh to watch vmstat and according to vmstat, we're not waiting on IO.  CPU load is negligable, RAM is fine, not waiting for IO, the server load is/should be very low.

The only way I've found to recover from this degraded performance is to reboot the VMguest.  This does not seem to affect Windows guests, nor BSD variants.  If I clone the affected machine to another VMhost, it runs fine.  If I reinstall the VMhost the problem persists.  It seems like either a hardware compat. issue or a problem with my configuration of the VMhost, but I've never been able to track it down, and have seen it occur in 20+ VMhosts.

The problem does not occur when I use another hypervisor technology such as KVM or even Virtualbox, on the same hardware.

Anyone else?

0 Kudos
emiel201110141
Contributor
Contributor

I have exactly the same frustrating problem... running Debian or Ubuntu causes read write operations to be extremely slow when the server is up for an hour or so. When I reboot the server everything feels fine and smooth again.

The weird part is that I only experience this on my linux machines and not on my Windows 2008 guest.

Dell PowerEdge T110

Xeon X3430

8 GB ECC RAM

2x 1TB RAID1

1x 2TB pushed raw to Debian guest

This problem is driving me crazy for more then a year now. If anybody has the same symptoms or can help us with a sollution that would be great. At least I know I'm not the only one...

0 Kudos
nevada201110141
Contributor
Contributor

Hi,

I found out after much research on forums that setting the CPU number to "one" solves the problem.

It has something to do with the OS waiting for the availability of all the requested CPU before processing the information.

Anyway, the wait for only one processor is much lower that two or four.

Try this, it works for me.

Cheers.

0 Kudos