VMware Cloud Community
paradxum
Contributor
Contributor

USB Passthru Errors for Tripplite USB UPS

I've been having a problem with intermittent (mostly failing) connection to a tripplite usb ups only when using vmware passthru.

I have confirmed this with at least 3 tripplite usb ups's. I have also confirmed that the entire setup works perfect on a non-vmware setup, or with an APC ups.

Setup:

vmware 6.0 (fails on 5.x too)

Virt Server configured with usb passthru for device (with both USB Controller AND USB xHCI Controller)

Client OS: CentOS 7.0 (fails on 6.x too)

UPS: TRIPP LITE SMART1500LCDXL (fails on other tripplite ups's too)

What happens: everything connects and works for a small amount of time (5-10 minutes) then ups usb connection "disconnects" and reconnects over and over.

Versions of monitoring software does not matter as it's a usb hid disconnect.

Relevant /var/log/messages entries:

Nov 24 06:56:12 kernel: usb 2-1: USB disconnect, device number 118

Nov 24 06:56:13 kernel: usb 2-1: new low-speed USB device number 119 using uhci_hcd

Nov 24 06:56:14 kernel: usb 2-1: New USB device found, idVendor=09ae, idProduct=2012

Nov 24 06:56:14 kernel: usb 2-1: New USB device strings: Mfr=1, Product=2, SerialNumber=0

Nov 24 06:56:14 kernel: usb 2-1: Product: Tripp Lite UPS

Nov 24 06:56:14 kernel: usb 2-1: Manufacturer: Tripp Lite

Nov 24 06:56:24 kernel: hid-generic 0003:09AE:2012.7000: usb_submit_urb(ctrl) failed: -1

Nov 24 06:56:24 kernel: hid-generic 0003:09AE:2012.7000: timeout initializing reports

Nov 24 06:56:24 kernel: hid-generic 0003:09AE:2012.7000: hiddev0,hidraw0: USB HID v1.10 Device [Tripp Lite  Tripp Lite UPS ] on usb-0000:02:00.0-1/input0

Nov 24 06:56:29 kernel: usb 2-1: USB disconnect, device number 119

Nov 24 06:56:30 kernel: usb 2-1: new low-speed USB device number 120 using uhci_hcd

Nov 24 06:56:31 kernel: usb 2-1: New USB device found, idVendor=09ae, idProduct=2012

Nov 24 06:56:31 kernel: usb 2-1: New USB device strings: Mfr=1, Product=2, SerialNumber=0

Nov 24 06:56:31 kernel: usb 2-1: Product: Tripp Lite UPS

Nov 24 06:56:31 kernel: usb 2-1: Manufacturer: Tripp Lite

Nov 24 06:56:41 kernel: hid-generic 0003:09AE:2012.7001: usb_submit_urb(ctrl) failed: -1

Nov 24 06:56:41 kernel: hid-generic 0003:09AE:2012.7001: timeout initializing reports

Nov 24 06:56:41 kernel: hid-generic 0003:09AE:2012.7001: hiddev0,hidraw0: USB HID v1.10 Device [Tripp Lite  Tripp Lite UPS ] on usb-0000:02:00.0-1/input0

Nov 24 06:56:46 kernel: usb 2-1: USB disconnect, device number 120

Nov 24 06:56:47 kernel: usb 2-1: new low-speed USB device number 121 using uhci_hcd

Nov 24 06:56:48 kernel: usb 2-1: New USB device found, idVendor=09ae, idProduct=2012

Nov 24 06:56:48 kernel: usb 2-1: New USB device strings: Mfr=1, Product=2, SerialNumber=0

Nov 24 06:56:48 kernel: usb 2-1: Product: Tripp Lite UPS

Nov 24 06:56:48 kernel: usb 2-1: Manufacturer: Tripp Lite

Nov 24 06:56:58 kernel: hid-generic 0003:09AE:2012.7002: usb_submit_urb(ctrl) failed: -1

Nov 24 06:56:58 kernel: hid-generic 0003:09AE:2012.7002: timeout initializing reports

Nov 24 06:56:58 kernel: hid-generic 0003:09AE:2012.7002: hiddev0,hidraw0: USB HID v1.10 Device [Tripp Lite  Tripp Lite UPS ] on usb-0000:02:00.0-1/input0

Does anyone have a solution for this. Besides "Buy an APC ups"? I do believe this to be an error in vmware, is this the proper place to report this as a bug?

0 Kudos
0 Replies