rlagroup
Contributor
Contributor

Time Sync Errors

Hi,

I'm having real issues syncing the time from our PDC.

We are running ESXi 4.1 at the moment with the PDC sat on that. Our host doesn't have internet access so I have disabled the NTP server and manually set the time for now. This didn't work so I have set the NTP server to the hostname of our PDC but still no luck

Basically our DC has the wrong time and won't sync with anything other than the local CMOS clock:

Leap Indicator: 0(no warning)
Stratum: 1 (primary reference - syncd by radio clock)
Precision: -6 (15.625ms per tick)
Root Delay: 0.0000000s
Root Dispersion: 10.0000000s
ReferenceId: 0x4C4F434C (source name:  "LOCL")
Last Successful Sync Time: 20/08/2012 11:27:59
Source: Local CMOS Clock
Poll Interval: 6 (64s)

I have tried everything in this article on the DC but still the same issue where it only syncs with the Local CMOS Clock (http://technet.microsoft.com/en-us/library/cc773263.aspx#w2k3tr_times_tools_vwtt)

Any help would be greatly appreciated

Cheers,

18 Replies
a_p_
Leadership
Leadership

Two quick thoughts about this:

w32tm /config /manualpeerlist:<peers> /syncfromflags:MANUAL /reliable:YES /update

should work to configure the time service on the first DC to synchronize its time with <peers> (i.e. one or more time servers)

It is not recommended to sync the ESXi host time from a VM running on the host. This can introduce issues! Maybe you can configure a switch to act as a time server!?

André

0 Kudos
rlagroup
Contributor
Contributor

I've tried running w32tm /config /manualpeerlist:0.uk.pool.ntp.org,0x8 /syncfromflags:MANUAL /reliable:YES /update on the DC but its still saying its syncing with the Local CMOS Clock

I've not changed the NTP servers on the exsi to point to 0.uk.pool.ntp.org and 1.uk.pool.ntp.org

Still no luck though

0 Kudos
kastlr
Expert
Expert

Hi,

what exactly do you like to perform when your PDC doesn't have access to the internet and no local NTP server is available?

Regards

Ralf



Hope this helps a bit.
Greetings from Germany. (CET)
0 Kudos
a_p_
Leadership
Leadership

Is it the same without specifying "0x8" in the command?

André

0 Kudos
rlagroup
Contributor
Contributor

The PDC has access to the internet the host doesn't have access.

So the Server 2008 DC can access the internet fine but the machine running the esxi doesn't have access to the internet if that makes sense?

I'm trying to get the PDC to use an external NTP server not a local NTP server but everything I am trying doesn't work

0 Kudos
rlagroup
Contributor
Contributor

Yeah, i've tried it with and without the 0x8 command and also tried using an IP for the NTP server rather than a hostname

0 Kudos
a_p_
Leadership
Leadership

I did this just a few days ago and - apparently due to UAC settings - had to open the command prompt using "Run as Administrator" to make it work.

André

0 Kudos
rlagroup
Contributor
Contributor

I've just tried again running CMD as administratir but still no joys

I've also changed it manually in the registry and that still hasn't worked Smiley Sad

0 Kudos
a_p_
Leadership
Leadership

I think you may be looking at the wrong status. w32tm /query /status returns the status of the local system which gets the time from its CMOS clock. However w32tm /query /peers and/or w32tm /query /configuration show the NTP server which is used to synchonize the local time with.

André

Message was edited by: a.p. - fixed typos

rlagroup
Contributor
Contributor

These are the two outcomes from those commands:

#Peers: 1

Peer:
State: Pending
Time Remaining: 877.3437500s
Mode: 0 (reserved)
Stratum: 0 (unspecified)
PeerPoll Interval: 0 (unspecified)
HostPoll Interval: 0 (unspecified)

and

EventLogFlags: 2 (Local)
AnnounceFlags: 5 (Local)
TimeJumpAuditOffset: 28800 (Local)
MinPollInterval: 6 (Local)
MaxPollInterval: 10 (Local)
MaxNegPhaseCorrection: 1800 (Local)
MaxPosPhaseCorrection: 1800 (Local)
MaxAllowedPhaseOffset: 300 (Local)

FrequencyCorrectRate: 4 (Local)
PollAdjustFactor: 5 (Local)
LargePhaseOffset: 50000000 (Local)
SpikeWatchPeriod: 900 (Local)
LocalClockDispersion: 10 (Local)
HoldPeriod: 5 (Local)
PhaseCorrectRate: 7 (Local)
UpdateInterval: 100 (Local)


[TimeProviders]

NtpClient (Local)
DllName: C:\Windows\system32\w32time.DLL (Local)
Enabled: 1 (Local)
InputProvider: 1 (Local)
CrossSiteSyncFlags: 2 (Policy)
AllowNonstandardModeCombinations: 1 (Local)
ResolvePeerBackoffMinutes: 15 (Policy)
ResolvePeerBackoffMaxTimes: 7 (Policy)
CompatibilityFlags: 2147483648 (Local)
EventLogFlags: 0 (Policy)
LargeSampleSkew: 3 (Local)
SpecialPollInterval: 3600 (Policy)
Type: NT5DS (Policy)

NtpServer (Local)
DllName: C:\Windows\system32\w32time.DLL (Local)
Enabled: 1 (Local)
InputProvider: 0 (Local)
AllowNonstandardModeCombinations: 1 (Local)

VMICTimeProvider (Local)
DllName: C:\Windows\System32\vmictimeprovider.dll (Local)
Enabled: 1 (Local)
InputProvider: 1 (Local)

I could be reading it wrong but it still all looks like its using a local time source?

0 Kudos
a_p_
Leadership
Leadership

This is indeed strange. I just tried the same on my lab DC (which runs with default Windows policies). Here's what I get:

C:\>w32tm /config /manualpeerlist:some.timeserver.net /syncfromflags:MANUAL /reliable:YES /update

The command completed successfully.

C:\>w32tm /query /peers

#Peers: 1

Peer: some.timeserver.net
State: Pending
Time Remaining: 875.3083758s
Mode: 0 (reserved)
Stratum: 0 (unspecified)
PeerPoll Interval: 0 (unspecified)
HostPoll Interval: 0 (unspecified)

C:\>w32tm /query /configuration

[Configuration]

EventLogFlags: 2 (Local)
AnnounceFlags: 5 (Local)
TimeJumpAuditOffset: 28800 (Local)
MinPollInterval: 6 (Local)
MaxPollInterval: 10 (Local)
MaxNegPhaseCorrection: 172800 (Local)
MaxPosPhaseCorrection: 172800 (Local)
MaxAllowedPhaseOffset: 300 (Local)

FrequencyCorrectRate: 4 (Local)
PollAdjustFactor: 5 (Local)
LargePhaseOffset: 50000000 (Local)
SpikeWatchPeriod: 900 (Local)
LocalClockDispersion: 10 (Local)
HoldPeriod: 5 (Local)
PhaseCorrectRate: 7 (Local)
UpdateInterval: 100 (Local)


[TimeProviders]

NtpClient (Local)
DllName: C:\Windows\system32\w32time.dll (Local)
Enabled: 1 (Local)
InputProvider: 1 (Local)
CrossSiteSyncFlags: 2 (Local)
AllowNonstandardModeCombinations: 1 (Local)
ResolvePeerBackoffMinutes: 15 (Local)
ResolvePeerBackoffMaxTimes: 7 (Local)
CompatibilityFlags: 2147483648 (Local)
EventLogFlags: 1 (Local)
LargeSampleSkew: 3 (Local)
SpecialPollInterval: 3600 (Local)
Type: NTP (Local)
NtpServer: some.timeserver.net (Local)

NtpServer (Local)
DllName: C:\Windows\system32\w32time.dll (Local)
Enabled: 1 (Local)
InputProvider: 0 (Local)
AllowNonstandardModeCombinations: 1 (Local)

VMICTimeProvider (Local)
DllName: C:\Windows\System32\vmictimeprovider.dll (Local)
Enabled: 1 (Local)
InputProvider: 1 (Local)

André

0 Kudos
rlagroup
Contributor
Contributor

Hmmm something looks to be forcing mine to use NT5DS rather than NTP - im a bit stumped now though :smileyplain:

0 Kudos
a_p_
Leadership
Leadership

Just one more thought. Please check whether this DC holds the PDC Emulator role (netdom /query fsmo).

André

0 Kudos
rlagroup
Contributor
Contributor

This DC holds the Schema Master, Domain Naming Maseter, PDC and RID Pool Manager

0 Kudos
ninoch
Contributor
Contributor

Im having the exact issue with the time synchronization.

I have been trying to set the server6 as the time server.

This is what I get when I do netdom /query fsmo

c:\>netdom /query fsmo
Schema master                   server9
Domain naming master        Server6
PDC                                   Server6
RID pool manager               Server6
Infrastructure master           server9

The command completed successfully.

Any guidance will be greatly appreciated. Thanks

0 Kudos
yani1shu
Contributor
Contributor

Was this problem ever resolved? I'm having the exact same issue with my server.

0 Kudos
systimax
Contributor
Contributor

Anyone ever figure this out?

Same problem as a few of the others.

0 Kudos
ThompsG
Virtuoso
Virtuoso

Hi,

Sorry I know I'm a little late to the party but if you are having the same issues as the poster with the same rough outcome after running the w32tm commands, then I suspect that you have a group policy that is setting the Windows Time Service settings. If you take a look at the below screenshot taken from a previous response you can see the highlight in yellow sections are set by group policy:

W32TM Configuration Output.jpg

Do a gpresult or rsop (depreciated) on the Domain Controller and you should be able to locate the policy that is doing this. Remove it or rather stop it applying to your Domain Controllers and after a gpupdate all should return to normal.

Kind regards.