AmazingTed
Enthusiast
Enthusiast

Terrifying Copy Speeds!

Supermicro Box with a MegaRaid 9361-8i RAID Controller 12Gb/s 2GB Cache, with a mixture of SAS and SATA 6Gb/s 7200rpm disks. Plenty of memory and 2 multicore CPU's.

Disks are in a RAID0 Config, created a Datastore using the entire contents of the disks, try to subsequently upload a 5GB iso file to the new Datastore, copying at less that 10MB/s over a 1Gb/s Ethernet network.

Completely unusable, as far as i can see this LSI MegaRAID card IS on the VMWare HCL.

Any ideas whatsoever?

Standalone ESX host running 6.7U2.

Tags (1)
0 Kudos
7 Replies
scott28tt
VMware Employee
VMware Employee

Moderator: Moved to ESXi


-------------------------------------------------------------------------------------------------------------------------------------------------------------

Although I am a VMware employee I contribute to VMware Communities voluntarily (ie. not in any official capacity)
VMware Training & Certification blog
0 Kudos
KabirAli82
Expert
Expert

The specs seem fine to me. What about the specs of the old datastore/system?

Did you check of you're all up2date in regards of firmware/drivers?

VMware Compatibility Guide - I/O Device Search


Was I helpful? Give a kudo for appreciation!
Braindumping @ http://kablog.nl/
Tweeting @ https://twitter.com/_Kabir_Ali_
0 Kudos
AmazingTed
Enthusiast
Enthusiast

Waiting for the restore to complete but i will then install this:

https://my.vmware.com/group/vmware/details?downloadGroup=DT-ESXI67-AVAGO-LSI-MR3-77051100-1OEM&produ...

Which i think is the latest firmware/driver combo for this adapter for 6.7U2.

0 Kudos
KabirAli82
Expert
Expert

Thats not the latest, you could also try the latest;

Download VMware vSphere

lsi_mr3 version 7.708.07.00-1OEM.6704.680.00-8454916

Was I helpful? Give a kudo for appreciation!
Braindumping @ http://kablog.nl/
Tweeting @ https://twitter.com/_Kabir_Ali_
0 Kudos
AmazingTed
Enthusiast
Enthusiast

Thats for ESXi 6.7U3 though, will it be backwards compatible to U2?

0 Kudos
KabirAli82
Expert
Expert

Thats funny, cuz this is the description:

ESXi 6.7 U2 (vSAN 6.7 Update 2)lsi_mr3 version 7.708.07.00-1OEM.6704.680.00-8454916asyncHybridView
Feature CategoryFeatures
vSAN CompatibleHybrid,Pass-Through
Footnotes  :Download driver from https://my.vmware.com/web/vmware/details?downloadGroup=DT-ESXI67-AVAGO-LSI-MR3-77080700-1OEM&product...

i'll change the link of my previous post


Was I helpful? Give a kudo for appreciation!
Braindumping @ http://kablog.nl/
Tweeting @ https://twitter.com/_Kabir_Ali_
0 Kudos
AmazingTed
Enthusiast
Enthusiast

Updated the drivers, but no difference that i can see, pre driver update i was getting approx 418MB/Min (6.9MB/s) updated the drivers using the Offline bundle and after the host rebooted approx 419MB/min (6.9MB/s)

However, when i performed the same copy using the Flash interface and NOT the HTML5 interface i was getting 1394MB/min (23MB/s) Didn't test this host in flash pre driver update.

So i did the same thing on a different host with the same RAID controller:

Upload in HTML5 interface pre driver install: 500MB/min (8.3MB/s)

Upload in Flash interface pre driver install: 1007MB/Min (16.7MB/s)

Upload in HTML5 interface Post Driver install: 430MB/min (7.1MB/s)

Upload in Flash interface Post Drive install: 858MB/Min (14.3MB/s)

However that said even at the fastest upload speed you would be wanting more than 23MB/s!

So it seems the upload method might have something to do with the slow speeds?

This is all over a 1GB ethernet network as well, if i copy files to my production, albeit much better spec VM's/hosts im getting 100MB/s copy speeds writing to VMDK HDD files presenting as Windows volumes, so its not a network bottlenext and this is all from the same source server which also eliminates that.

Plan to try and update the firmware on the RAID controller this afternoon, but its supposed to have a 2GB Cache so i should be getting much better than 23MB/s and this it to a RAID0 volume as well!

0 Kudos