Highlighted
Contributor
Contributor

TLS & Snap Shot commands

Hi All,

1, I need to check EXSi 5.5 TLS version in command line

2, We have EXSi 5.5 with 45 VMs I need to check how many VMs have snapshot in command line

Thanks

0 Kudos
9 Replies
Highlighted
VMware Employee
VMware Employee

‌Moderator note: Product question, so moved to the correct forum area - ESXi 5.


Forum Usage Guidelines: https://communities.vmware.com/docs/DOC-12286
VMware Training & Certification blog: http://vmwaretraining.blogspot.com
0 Kudos
Highlighted
Hot Shot
Hot Shot

There is no TLS version for ESX. TLS is a protocol used for communication for different services. ESX has different services which uses different versions of TLS for communication

You can use nmap or openssl to scan ports in ESX. There is a KB which lists all ports in ESX, so you can scan against various ports and find out which protocols are supported by different services in ESXi

You can use the below script to find out the snapshot info

for i in `vim-cmd vmsvc/getallvms |awk '{print $1}'`

do

vim-cmd vmsvc/get.snapshotinfo $i

done

0 Kudos
Highlighted
Virtuoso
Virtuoso

Hi rvkrish25,

What command-line tool do you want to use? Is PowerCLI okay or were you wanting native ESXi console commands?

Kind regards.

0 Kudos
Highlighted
Contributor
Contributor

Hi Thomps,

Please share me the ESXi console commands

Thanks

0 Kudos
Highlighted
Contributor
Contributor

Hi,

IF TLS is not support for EXSi 5.5 please share me the command to check for EXSi 6.0

Thanks

0 Kudos
Highlighted
Hot Shot
Hot Shot

Hi,

Commands to do what exactly?? Without knowing what you are trying to do is difficult.

JailBreak ICT Senior Infrastructure Engineer Tech Lead for VMware / Virtual Backups If helpful Please award points Thank You Technical Articles: Blog: www.provirtualzone.com | Twitter: @Luciano_PT
0 Kudos
Highlighted
Contributor
Contributor

Hi,

We have Vulnerability for EXSi 6.0 need to enable TLS but as per the document ( VMware ESXi 6.0 Update 1b Release Notes ) we need to upgrade 6.0 1b,

but it seems EXSi 6.0 with TLS version 1.0

Hence I need to find the current TLS version in EXSi 6.0 in command line

Thanks

0 Kudos
Highlighted
Hot Shot
Hot Shot

Hi

Here are the TLS and service supported: https://kb.vmware.com/kb/2136185

But still do not understand what you need to accomplish. You need a connection, or ESXi shell console?

JailBreak ICT Senior Infrastructure Engineer Tech Lead for VMware / Virtual Backups If helpful Please award points Thank You Technical Articles: Blog: www.provirtualzone.com | Twitter: @Luciano_PT
0 Kudos
Highlighted
Contributor
Contributor

Hi,

I already answered that need to check the TLS related in EXSi in CLI

Thanks

0 Kudos