arthuretf
Contributor
Contributor

Strange issues with webcam + Linux

I have a server machine hosting a Linux VM using VMWare vSphere 6.0. I am trying to get a webcam to work with it. However, I've been having two main issues:

  1. The frame rate is extremely low (0.1fps - 1.0fps).
  2. The output image has several glitches (as seen in the examples below).

I tried to install multiple Linux distributions (i.e. CentOS, Ubuntu 14.04 and 16.04, Mint 18.1), and the results are the same. I also tried with two different webcams: Microsoft LifeCam Cinema HD and a generic one (Sunplus Technology). Both cameras work fine on a physical machine running Mint and Ubuntu.

However, both cameras also work just fine on a Windows 10 running on a Virtual Machine at the same server.

To give some technical details, the following message gets printed very frequently when I run guvcview on Linux:

V4L2_CORE: Could not grab image (select timeout): Resource temporary unavailable.

I also captured 2 images using "guvcview" to show how the image quality is. One of them was using MJPG:

screen.png

and the other one with RGB3:

screen2.png

The remaining "camera output" options had poor quality results as well. Additionally, as you can see at the top bar, the frame rate is very low.

It is important to note that I also tried to capture the frame using multiple methods besides "guvcview", such as "streamer", "webcam" and OpenCV.

Would anyone know how to solve this problem? Thank you!

I also posted this question on superuser: http://superuser.com/questions/1162697/strange-issues-with-webcam-linux-vmware

0 Kudos
1 Reply
Nithy07cs055
Hot Shot
Hot Shot

May be the issue is with the Kernel version ?? check if the updates are present and also try to check which version of guvcview present ?

this thread should be helpful for you


https://bbs.archlinux.org/viewtopic.php?id=190524

Thanks and Regards, Nithyanathan R Please follow my page and Blog for more updates. Blog : https://communities.vmware.com/blogs/Nithyanathan Twitter @Nithy55 Facebook Vmware page : https://www.facebook.com/Virtualizationworld
0 Kudos