Fergieman201110
Contributor
Contributor

Staging upgrade to vsphere 5.1

Hello All

I am just looking for some advice regarding upgrading my current vsphere 5.0 to vsphere 5.1

I would like to stage the upgrade so I don't have to do every piece during the weekend.

What parts can I install/upgrade before upgrading the hosts themselves ?

What I mean is , if I install the SSO part and webclient will that impact my current environment or access into my vcenter via my vpshere 5 client?

Rgs

F

4 Replies
a_p_
Leadership
Leadership

Unless you have any dependencies and/or 3-rd party applications or tools relying on vCenter Server, you can actually upgrade all components for vCenter Server prior to upgrading the hosts. Please ensure the versions you use are compatible by checking the VMware Product Interoperability Matrix

In addition to vCenter Server you may also be able to upgrade e.g. backup software, ...

André

Fergieman201110
Contributor
Contributor

Thanks for your reply

If I upgrade Vcenter to 5.1 can I still connect to it via the 5.0 client?

Also , will the hosts/vms work fine with 5.1 if the hosts are still running 5.0 ?

Rgs

F

0 Kudos
weinstein5
Immortal
Immortal

Yes you should have no issues with vCenter at 5.1 and everything at 5.0 - VMware designed it to work like this

If you find this or any other answer useful please consider awarding points by marking the answer correct or helpful
0 Kudos
a_p_
Leadership
Leadership

If I upgrade Vcenter to 5.1 can I still connect to it via the 5.0 client?

You will need to install the new vSphere Client, which coexists with the currently installed one(s). This means you can still use the vSphere Client to connect to the hosts directly if needed. Also keep in mind that managing vSphere 5.1 should be done using the Web Client. Some of the new features (e.g. live migration without shared storage, new virtual hardware versions, ...) are only available in the Web Client.

Also , will the hosts/vms work fine with 5.1 if the hosts are still running 5.0 ?

According to the Matrix I mentioned, ESXi 5.0 hosts are supported with vCenter Server 5.1, so this shouldn't cause any issues.

André

0 Kudos