Highlighted
Enthusiast
Enthusiast

Slow vSphere Client 4.1.0 in W7-64bit (but OK in XP-Pro 32bit guest)

Jump to solution

I've found several discussions about this issue (eg http://communities.vmware.com/message/1501167#1501167, http://communities.vmware.com/message/1448377#1448377, etc) in Windows 7, but I've also found that the same vSphere Client version accessing the same ESXi server is running OK in XP guest.  It worths noting that the XP guest is running INSIDE my Windows 7 host!

OK, here are my specs:

Win7 runtime (host) computer:

CPU: Intel Cotre 2 Quad Q9550 @ 2.83GHz

RAM: 8GB DDR3 @ 1067MHz

Hard drive: 640 GB, SATA II, 7200 rpm

O/S: Windows 7 Ultimate 64 bit

XP runtime (guest) computer:

CPU: 2.83GHz (1 core)

RAM: 256 MB

Hard drive: 8GB

O/S: Windows XP Pro 32 bit

ESXi version = 4.1.0 (build 348481)

vSphere Client version = 4.1.0-345043

The client problem in Win7 is that I could see clearly the order by which it draws the graphical components one-by-one (eg the squares, the scroll bars, the small icons, the column header squares, etc) on the screen!  While on XP, the content is almost instantaneously drawn!

For example, the first time I click on "Summary" tab, it took about 6 seconds to draw everything!  The second time I click on it is better: about 2 seconds.

Resource Allocation: 5 sec

Performance: 4 sec

Configuration: 2 sec

  Config then Storage: 2 sec

etc, etc

This makes me turn to guest XP to run this snail client.  Very unbelievable!

I don't know .... is it a problem with .NET???

0 Kudos
1 Solution

Accepted Solutions
Highlighted
Virtuoso
Virtuoso

The vSphere Client runs slow on any system running Aero visualization.

Right click on the shortcut to the vSphere client (or application itself), go to the Compatibility tab, and check the box "Disable desktop composition". This will change your visuals to basic mode whenever the vSphere client is run, and will drastically improve draw speed on the client.

VCDX #104 (DCV, NV) ஃ WahlNetwork.com ஃ @ChrisWahl ஃ Author, Networking for VMware Administrators

View solution in original post

0 Kudos
4 Replies
Highlighted
Virtuoso
Virtuoso

The vSphere Client runs slow on any system running Aero visualization.

Right click on the shortcut to the vSphere client (or application itself), go to the Compatibility tab, and check the box "Disable desktop composition". This will change your visuals to basic mode whenever the vSphere client is run, and will drastically improve draw speed on the client.

VCDX #104 (DCV, NV) ஃ WahlNetwork.com ஃ @ChrisWahl ஃ Author, Networking for VMware Administrators

View solution in original post

0 Kudos
Highlighted
Enthusiast
Enthusiast

Yes, indeed!

Is VMware going to make it work better with Aero?  Because everytime the client is running, it's sort of "switching" the whole screen.  Very unpleasant and user-unfriendly.

0 Kudos
Highlighted
Virtuoso
Virtuoso

I certainly hope so, but I have not heard anything. I use a 2008 R2 VM as my primary workstation, so it's a non issue for me, but I really disliked having to turn off Aero on my Windows 7 laptop. Smiley Sad

VCDX #104 (DCV, NV) ஃ WahlNetwork.com ஃ @ChrisWahl ஃ Author, Networking for VMware Administrators
0 Kudos
Highlighted
Contributor
Contributor

Hello,

This problem re-appear since i have upgrade all : vcenter 4.1 to U2, Vsphere 4.1 to build 582267 and the vsphere client too.

With vsphere client, slow video display under Win7 64. So i have installed vnc server in the clients and i work with vnc client : it's faster...

but the display is not so slow with VM running linux, just with VM running windows 32bits.

i have tried with "Disable desktop composition" : not really faster.

i have tried under win xp : not really faster.

i hope an update from VMWare.

...

0 Kudos