farhal
Contributor
Contributor

Session is not Authenticated

Hi

I am not sure if this issue is related to ESXi or Zabbix, but I have a few ESXi hosts which are being monitorred by Zabbix.
On one of the hosts, I am not able to retrieve the snmp stats and zabbix displays the following errors "The session is not Authenticated".

I have configured and resterted snmp multiple times on the ESXi but the issue persists. All the snmp settings are same on all hosts, but only one host is having this issue.

Can someone help me please?

0 Kudos
3 Replies
Lalegre
Commander
Commander

Hey farhal​,

Check the next:

  • SNMP version to using is the correct one.
  • If using SNMP v3 check that the algorithm and the authentication is the same.
  • If using SNMP v2 check that the community matches.
  • Make sure to use HTTPS for the connectivity in the URL.
  • Check the permissions of the user created to be read-only.

And please follow the next procedure to configure everything: Configure ESXi for SNMP v3

0 Kudos
farhal
Contributor
Contributor

Hi Lalegre

Thanks for the update.

  • I am using SNMPv2,
  • The community is same on both ESXi and Zabbix
  • Also using HTTPS for the url
  • Permissions are correct as well, read-only (have tried changing to Admin but doesn't work either)
0 Kudos
Lalegre
Commander
Commander

Is this ESXi connected to vCenter Server? If it is have you configured the required Macros as per Zabbix documentation?

https://www.zabbix.org/wiki/Esxi_standalone_template

0 Kudos