thetoolguy
Contributor
Contributor

Server Time Source - Keeps Changing back to "Local CMOS Clock"

Hey everyone:

I'm fairly new to this stuff, so please be gentle.  I work for a very small manufacturing company with a single server that does pretty much everything for our network.  I'm using VMSphere Client v5.1 to manage the server client, which is running Windows Server 08 R2, SP1.

This server is the domain controller for all our client machines and also is the brain for our main database software called JobBoss.  This software also manages our direct labor employees time clock through a lightweight software package run from the client machines.  (Some of the clients are Win7 and there's even a couple old XP machines out there that don't do anything but time clock.)

I originally started looking into the time source issue because hourly employees would open the time clock software, which displays the current time, and sometimes it would be different from the time shown in the task bar by several minutes.  So I did some research and dug into trying to get all my client machines to sync their time from the server.  (My initial research found the the time clock software displays the 08 Server time, regardless of what the local client time is set to).

The first thing that I found was that when I ran this command from the server:  "w32tm /query /source" the result was always "Local CMOS Clock".  Further research told me that since the server didn't consider itself to be authoritative and reliable, the clients were often doing their own thing, which I can't have.

So I ran this series of commands on the server and had some success:

w32tm /config /manualpeerlist:"pool.ntp.org time.windows.com" /syncfromflags:manual /reliable:yes /update

TIMEOUT /T 30

net stop w32time && net start w32time

TIMEOUT /T 30

w32tm /query /source

TIMEOUT /T 30

This would update the query results to show one of the two external servers as the source.  Then I would check my clients and find them to be using my Windows server as the source.  Great.  However, when I would check in on the server again later, it would have reverted back to "Local CMOS Clock" again.  Very frustrating.

As of right now, I've created a batch file of those commands above, and set it to run every few hours.  And quite often, I'll check it and it will still be set to the local CMOS clock.  In addition, sometimes I have to run that command 4 or 5 times before it will actually take and display the final query results of something other than the CMOS clock.  In other words, it doesn't always work.

FYI - In the vSphere client software, when I click on the Configuration tab, then go to "Time Configuration" in the "Software" section, it displays a current date and time.  NTP Client Status is Running, NTP Servers are pool.ntp.org.  When I click on Properties in the upper right, the dialog box comes up that says "NTP Client Enabled".  In the options box, the status is "Running" and it's set to start automatically. 

So what am I missing?  Why does Windows keep reverting back to the CMOS clock instead of doing what I tell it to?  Any help is appreciated.  Thanks for reading!

0 Kudos
0 Replies