jonq
Contributor
Contributor

Server Communication

Jump to solution

Hello Everyone,

We recently purchased VMWare VSphear Essentials. I built a new ESXi virtual server and installed a new guest Windows 2003 server on it. we are not doing anything fancy with it. We just wanted to better utilise our hardware and we now use Veeam for backup. Our accounting software that runs on the windows 2003 works, but when we try to connect to it from our clients the software wont connect. The company that supports the software says they dont support virtual servers because virutal servers dont allow the programs to communicte the way a real physical server does. is this true? is there anything from the VMware side of the system we can work with to make this work?

I know i havent give very much spacific information about the issue but i am just confused why the virtual server wont communicate to the clients. i can browse the server from \\servername\ i can vnc into, remote desktop into it. it looks like it is working perfect on the network...just the custome software client fails to "see" the server.

Any help would be appricated! Thank You!

0 Kudos
1 Solution

Accepted Solutions
Saadat
Enthusiast
Enthusiast

I am glad it worked out for you.

You can close your topic so everyone will know the problem is resolved.

http://www.linkedin.com/in/ernestsaadat

View solution in original post

0 Kudos
14 Replies
DSTAVERT
Immortal
Immortal

Sounds like you need a new accounting system.

A virtual server behaves just like a physical server. Networking is the same physical or virtual. I would start looking at this as any normal troubleshooting session. Confirm everything especially firewall settings in the guest OS. Does the system work when using the client from the same server is installed on?

-- David -- VMware Communities Moderator
0 Kudos
Saadat
Enthusiast
Enthusiast

Before virtualizing a server, it is better to check with the vendor if they support it or not.

In a lot of cases, vendors don't have resources to do the QA so they just blame the Virtualization and say that we don't support it.

If you really need their support you have to follow thier rules. But if this company has a lot of request on support on virtualization, then they will start doing their QA, otherwise they will lose their client.

Here is two links from VMware and Microsoft about Microsoft product line support with Virtualization:

http://www.vmware.com/support/policies/ms_support_statement.html

http://support.microsoft.com/kb/957006/

As you can see, even something like SQL Server is supported on VMware.

But I didn't get exactly what you meant by Clients cannot connect to the VM. is the VM behind a firewall?

http://www.linkedin.com/in/ernestsaadat
jonq
Contributor
Contributor

HaHa, i agree with the new accounting system. unfortuatly that is not an option at this time Smiley Sad.

the client does work from the server itself. but the same client does not work from any other workstation. When i ask how the system communicates to help me better understand the problem, the software vender refuses to tell me, saying they will not facilitate me loading there system on an unsupported installation. All i can tell is it uses MSSql express and ActiveX controlls of some type.

The firewall is off on the windows 2003 server.

0 Kudos
jonq
Contributor
Contributor

the clients "see" the server. can browse the server. our text based accounting system uses telnet and it works great. but the graphical client will not connect.

I did contact the vender prior purchasing VMWare and the tech i said that virtualzation was the way to go, but now everone i talk to at the company says no way. and of course i didnt write down the name of the tech that i talked to first Smiley Sad

we have a very simple network, no domain, just a file and print server, and now an esxi server.

I am tempted that if i have to start from scratch (which i dont want to) to use vmware converter and try to build a phiscal server that we can get up and running with help, and then convertit and see what happens.

0 Kudos
Saadat
Enthusiast
Enthusiast

I still think that there is a misconfiguration on Virtual machine. How did you create this VM?

P2V? or you build it from scratch?

http://www.linkedin.com/in/ernestsaadat
0 Kudos
DSTAVERT
Immortal
Immortal

These days any company that uses virtualization as an excuse for refusing to provide support needs a wake up call. While a company may not support virtualization of it's product is no excuse for not providing best effort support. As I said this should be a troubleshooting exercise not a virtualization one. There should be nothing about virtualization that would prevent an application from functioning.

-- David -- VMware Communities Moderator
jonq
Contributor
Contributor

I built it from scratch. a new vm and an iso of windows 2003 64bit. went threw the isntall, loaded updates and then loaded the acct software.

0 Kudos
Saadat
Enthusiast
Enthusiast

While you created the new Server, Did you use the same Server name or you created a new name?

If the same sever name, then you have to shutdown your physical Server while you are testing the Client connections. (Clear Cache on DNS in Clients, you have a new MAC Address for your server, or try to ping the Server name)

If you used a different name, sometimes you may need to reinstall the accounting application and just importing the database may not work.(You can get more support on guidlines of reinstallation of the accounting software if you claim you need Disaster Recovery solution and you should be able to re-create the Server, if your currnet server goes down)

What about the clients. Did you point them to the new Server?

What is the exact error message that you receive?

http://www.linkedin.com/in/ernestsaadat
0 Kudos
jonq
Contributor
Contributor

I think it is a problem with the com+ components as some dll's did not register correctly while installing (maybe because this is 64 bit windows? the software company did say they support 64bit server). The important thing i was looking for was VMWare causeing any communiction problems, which i didnt think it would. My only issue now is that our software provider is not willing to help us.

Thank you everyone for your help!

0 Kudos
DSTAVERT
Immortal
Immortal

There can certainly 64bit problems. If this is a 32bit app and you don't have any specific need for 64bit I would remain at 32bit. If it isn't solving a problem don't use it.

-- David -- VMware Communities Moderator
0 Kudos
DSTAVERT
Immortal
Immortal

If there are forums for the application i would start posting asking for virtualization support. I can't imaging that the company couldn't greatly benefit from virtualization themselves. Virtualization is often used specifically for support. The ability to host many versions, combinations of OS etc.

Let us know how it works out.

Good luck.

-- David -- VMware Communities Moderator
0 Kudos
jonq
Contributor
Contributor

Funnie thing is that is what the company is useing! i talked to one of their techs and their interire system is running on VMs and the test center is on VMs. but their policy is they do not recomend runnign on a virtual server in a production enviroment...even though they do. i dont understand it, but i am not giving up yet! like i had said we belive it is a com issue, so tonight we are going to blow out the com+ and reinstall it. also i am already building another windows 2003 32 bit server and see if that makes a differenace doing a clean install on that. i have a feeling 32 bit might make a big differance. the reason for going with 64 bit was to take advantage of the larger ram limit with the databases. but i think 4 gig will be just fine if it works.

0 Kudos
jonq
Contributor
Contributor

Just FYI to everyone that helped out.

We reloaded a new server with 2003 32 bit and the install went perfect and we are up and running. the problem was the 64 bit all along. the software company still wont support the virtual server, so we leave that detail out if we have to call them for support.

Thank you again for everyones advise!

0 Kudos
Saadat
Enthusiast
Enthusiast

I am glad it worked out for you.

You can close your topic so everyone will know the problem is resolved.

http://www.linkedin.com/in/ernestsaadat

View solution in original post

0 Kudos