BaijuNSHFX
Contributor
Contributor

SSH root login denied

Jump to solution

Hi All,

I installed VCSA65 on an ESXi5.5 host and added that host to vCenter65 after that I am unable to SSH login to the root account.

The ESXi5.5 host root password is not accepting.

SSH is enabled on the server through vCenter65.

What might be the issue? do I need to turn on any other services or needs to verify any other logs?

0 Kudos
2 Solutions

Accepted Solutions
lukaszzasko
Enthusiast
Enthusiast

Hi,

You can check:

1. ssh configuration /etc/ssh/sshd_config and verify entry: "PermitRootLogin" - should be set to "yes"

2. lockdown mode "Normal" or "Strict" in ESXi: https://kb.vmware.com/s/article/1008077

View solution in original post

0 Kudos

vCenter may have turned off the SSH service.

On vSphere 7 you would log into vCenter, look at the settings for the host, under Configure > System > Services. If the SSH service is "Stopped", then start it. If you want the SSH service always enable, then edit the startup policy on the same web client page.

On vSphere 6.5, things may be a bit different to my description, but similar enough to get you to the right place. I my shaky memory serves me well, the services control is under Configure > System > Security Profile in vSphere 6.x.

View solution in original post

0 Kudos
7 Replies
maksym007
Hot Shot
Hot Shot

Maybe port 22 is blocked. Have you checked that?

0 Kudos
maksym007
Hot Shot
Hot Shot

almost forgot - what are you using for connection via SSH? probably well-known Putty. What version?

try with the latest/newest one

0 Kudos
lukaszzasko
Enthusiast
Enthusiast

Hi,

You can check:

1. ssh configuration /etc/ssh/sshd_config and verify entry: "PermitRootLogin" - should be set to "yes"

2. lockdown mode "Normal" or "Strict" in ESXi: https://kb.vmware.com/s/article/1008077

0 Kudos

vCenter may have turned off the SSH service.

On vSphere 7 you would log into vCenter, look at the settings for the host, under Configure > System > Services. If the SSH service is "Stopped", then start it. If you want the SSH service always enable, then edit the startup policy on the same web client page.

On vSphere 6.5, things may be a bit different to my description, but similar enough to get you to the right place. I my shaky memory serves me well, the services control is under Configure > System > Security Profile in vSphere 6.x.

0 Kudos
maksym007
Hot Shot
Hot Shot

this is very cool guys but he wrote already that SSH is enabled on host from vCenter level

0 Kudos

Hmm true. Has he tried the age old engineering trick of "turning off and then back on again"?

0 Kudos
BaijuNSHFX
Contributor
Contributor

Thank you .

It is due to the lockdown mode and it was enabled. Now I can login