bilalhashmi
Expert
Expert

SSH from MAC to ESXi

Jump to solution

I am sshing from my MAC to an ESXi box using the native terminal via the "ssh username@hostname" command. I can login and run a few commands without any issues, but when i run ESXTOP, it does't have the pretty display with columns like u would see on putty or any other clinet... trying to figure out what could cause this... do u know if there are any settings I can play with on my terminal.. I know esxtop works fine if I use windows and putty..

See the screenshot for my esxtop results from my mac

Blog: www.Cloud-Buddy.com | Follow me @hashmibilal
1 Solution

Accepted Solutions
kjb007
Immortal
Immortal

xterm xterm-color is the terminal emulation being used to display rows and columns to your screen.  So, when you connect from your client to your esxi host, the client tells what type of encapsulation to use.  If the server (esxi in this case), does not have the mode you are requesting, you get what you are seeing, where the rows and columns don't match up with the screen you are using.

xterm is the default / standard terminal emulator for x window systems and is used fairly widely.

xterm-color is more modern meant to use with modern servers where you get color highlighting added in, which esxi is not doing for you.

Hope that makes sense.

-KjB

vExpert/VCP/VCAP vmwise.com / @vmwise -KjB

View solution in original post

0 Kudos
12 Replies
kjb007
Immortal
Immortal

That looks like esxtop is running in batch mode.  Make sure there is no config file forcing this behavior for esxtop.

-KjB

vExpert/VCP/VCAP vmwise.com / @vmwise -KjB
bilalhashmi
Expert
Expert

I dont see that... I wonder if my problem is the terminal native client in MAC because the putty session in Win runs fine...

Follow me @ Cloud-Buddy.com

Blog: www.Cloud-Buddy.com | Follow me @hashmibilal
0 Kudos
Scissor
Virtuoso
Virtuoso

I saw similar esxtop display behavior in my SecureCRT SSH client until I changed my session terminal emulation from VT100 to ANSI.   Not sure how you would do that from the Mac ssh client though..

0 Kudos
kjb007
Immortal
Immortal

What do you get when you run 'echo $TERM' after you ssh into ESXi?

If something other than, xterm, run 'export TERM=xterm'

Then try the esxtop again.

-KjB

vExpert/VCP/VCAP vmwise.com / @vmwise -KjB
bilalhashmi
Expert
Expert

Thanks! I tried that and it came back to xterm-color so I followed what u said and it worked.. but when I relaucnhed the terminal it did the same thing until I followed ur instructions. SO what I did was I went in the terminal setting and made xterm as the default vs xterm-color. What is xterm or xterm-color? I just want to understand what this means so that I am aware of anything else that comes up in the future.. Thanks again...

Follow me @ Cloud-Buddy.com

Blog: www.Cloud-Buddy.com | Follow me @hashmibilal
0 Kudos
kjb007
Immortal
Immortal

xterm xterm-color is the terminal emulation being used to display rows and columns to your screen.  So, when you connect from your client to your esxi host, the client tells what type of encapsulation to use.  If the server (esxi in this case), does not have the mode you are requesting, you get what you are seeing, where the rows and columns don't match up with the screen you are using.

xterm is the default / standard terminal emulator for x window systems and is used fairly widely.

xterm-color is more modern meant to use with modern servers where you get color highlighting added in, which esxi is not doing for you.

Hope that makes sense.

-KjB

vExpert/VCP/VCAP vmwise.com / @vmwise -KjB

View solution in original post

0 Kudos
bilalhashmi
Expert
Expert

Thanks a lot for the detailed info.. thanks a bunch.. that exlains it..

Follow me @ Cloud-Buddy.com

Blog: www.Cloud-Buddy.com | Follow me @hashmibilal
0 Kudos
alietz
Contributor
Contributor

Thanks also from here, I've been having the issue of esxtop not displaying correctly when I ssh from the Mac to my ESXi host. I used resxtop from vMA, which works fine, too, but sometimes it's quicker to just be able to launch esxtop directly.

Is there a way to have the shell automatically use xterm insted of xterm-color?

Cheers,

   Andy

0 Kudos
bilalhashmi
Expert
Expert

Yes there is, under the Preferences of ur Terminal, click on "Settings" and then on "Advanced" and select "xterm" in the "Declare terminal as" field. See my screenshot below... good luck..

Follow me @ Cloud-Buddy.com

Blog: www.Cloud-Buddy.com | Follow me @hashmibilal
0 Kudos
alietz
Contributor
Contributor

That works perfectly, thank you.

0 Kudos
mineral
Contributor
Contributor

export TERM=xterm

It worked for me for ESXi5.0 & SecureCRT

0 Kudos
virtualinstall
Enthusiast
Enthusiast

Just had the same problem and this done the trick, thanks.

0 Kudos