vmrulz
Hot Shot
Hot Shot

SSD not showing up as local for vfrc

Jump to solution

I've got 100G SSD's in my HP BL460g8 servers. These are SAS attached via a p220i controller. I have enterprise+ licensing. They have not been formatted. When I attempt to add capacity to a host in Virt flash resource management I don't see anything.

I've been attempting to beat them into submission using the cli commands here: vSphere 5.5 Documentation Center

After setting the SATP disk option=enable_local it doesn't show up as local

~ # esxcli storage core device list -d naa.600508b1001c3b7559b32be63f27a8ba

naa.600508b1001c3b7559b32be63f27a8ba

   Display Name: HP Serial Attached SCSI Disk (naa.600508b1001c3b7559b32be63f27a8ba)

   Has Settable Display Name: true

   Size: 95362

   Device Type: Direct-Access

   Multipath Plugin: NMP

   Devfs Path: /vmfs/devices/disks/naa.600508b1001c3b7559b32be63f27a8ba

   Vendor: HP

   Model: LOGICAL VOLUME

   Revision: 3.42

   SCSI Level: 5

   Is Pseudo: false

   Status: degraded

   Is RDM Capable: true

  Is Local: false

   Is Removable: false

   Is SSD: true

   Is Offline: false

   Is Perennially Reserved: false

   Queue Full Sample Size: 0

   Queue Full Threshold: 0

   Thin Provisioning Status: unknown

   Attached Filters:

   VAAI Status: unknown

   Other UIDs: vml.0200010000600508b1001c3b7559b32be63f27a8ba4c4f47494341

   Is Local SAS Device: false

   Is Boot USB Device: false

   No of outstanding IOs with competing worlds: 32

Any ideas?

Thanks

Ron

1 Solution

Accepted Solutions
Gortee
Hot Shot
Hot Shot

I assume you have tried this but just in case:

esxcli storage nmp satp rule add –satp VMW_SATP_LOCAL –device naa.600508b1001c3b7559b32be63f27a8ba –option “enable_local enable_ssd”

This command also requires a reboot to be active.

Let me know if this does not work.

Thanks,

J

Joseph Griffiths http://blog.jgriffiths.org @Gortees VCDX-DCV #143

View solution in original post

2 Replies
Gortee
Hot Shot
Hot Shot

I assume you have tried this but just in case:

esxcli storage nmp satp rule add –satp VMW_SATP_LOCAL –device naa.600508b1001c3b7559b32be63f27a8ba –option “enable_local enable_ssd”

This command also requires a reboot to be active.

Let me know if this does not work.

Thanks,

J

Joseph Griffiths http://blog.jgriffiths.org @Gortees VCDX-DCV #143

View solution in original post

vmrulz
Hot Shot
Hot Shot

Ah I see, I wasn't sure you could double up the option commands. When you try to run them one at a time the second one gets an error. I'll try putting them together. Thanks for the reply!

Just ran it and it worked, thanks much!

0 Kudos