VMware Cloud Community

[SOLVED] Messed up with ESXi 6.5 to 6.7u2 update, Fujitsu Custom image


I have (had) standalone Fujitsu host on ESXi 6.5 Custom Fujitsu image and I went with upgrade yesterday to Custom Fujitsu image 6.7 Update 2. Since Fujitsu did not provide any reliable instructions, and they only mention to use vib install method, while VMWare explicitly says it only supports profile update method, I went with profile update like so:

esxcli network firewall ruleset set -e true -r httpClient

esxcli software profile update -p ESXi-6.7.0-20190404001-standard -d https://hostupdate.vmware.com/software/VUM/PRODUCTION/main/vmw-depot-index.xml

LOG ENTRY: Successfully updated host to image profile 'ESXi-6.7.0-20190404001-standard'. Installed 143 VIB(s), removed 125 VIB(s).

But since this was not FUJITSU customized image yet, I issued another command to push cusctomized VIBs from Fujitsu:

esxcli software vib update -d /vmfs/volumes/DATA-SAS1/ISO/VMware-ESXi-6.7.0-13473784-Fujitsu-v470-1-offline_bundle.zip

Installation Result

  Message: The update completed successfully, but the system needs to be rebooted for the changes to be effective.

  Reboot Required: true

LOG ENTRY: Successfully installed 17 VIB(s), removed 17 VIB(s).

Rebooted and host came up, console was visible like normal, IP and services up like normal....but it was not accessible via WEB, VMs did not power on, SSH not accessible...

So I used SHIFT-R to revert one image back...but unfortunately I could only revert from 6.7 to 6.7, and not back to 6.5. Looks like 6.5 was removed.
Also I tried with BOOT CD 6.7 installer, but the result was the same (probably because I upgraded already broken down host).

Any idea how to approach to rescue?

  • I cannot format boot disk, because there's one huge VM there, over 1.7 TB and I have no other local datastore to move it away.
  • I could eventually shrink one of the LOCAL RAID 10 arrays (if there are some reliable instructions), then create new ARRAY and install 6.5 or 6.7 fresh, then manually reconfigure all 11 VMs.
  • ....or should I install fresh ESX to bootable USB key? Performance vise would I loose anything vs. curent install, which uses local SSD RAID 10 array?
  • or any other method to repair broken ESX image


Issue kinda SOLVED by trying different ESXi images. Found out problem is that ESXi 6.7 U2 is NOT COMPATIBLE with my server Fujitsu Primergy RX2540 M2, despite of being on compatibility list! The latest successfully installed ESXi version was 6.5 U3.

0 Replies