Phrix
Contributor
Contributor

SCP SSH not working between ESXi hosts

Jump to solution

Hello,

I have two servers with ESXi 5, both I can access through ssh (putty) but I if try prompt the one of ESXi5 to other ESXi I can´t access, my ping works, I try use SCP between two but don´t work, see the error:

~ # ssh 192.168.0.251
ssh: connect to host 192.168.0.251 port 22: Connection timed out
~ # scp /tmp/testescp.txt root@192.168.0.251:/tmp
ssh: connect to host 192.168.0.251 port 22: Connection timed out
lost connection
PING 192.168.0.251 (192.168.0.251): 56 data bytes
64 bytes from 192.168.0.251: icmp_seq=0 ttl=64 time=0.157 ms
64 bytes from 192.168.0.251: icmp_seq=1 ttl=64 time=0.214 ms
64 bytes from 192.168.0.251: icmp_seq=2 ttl=64 time=0.187 ms
--- 192.168.0.251 ping statistics ---
3 packets transmitted, 3 packets received, 0% packet loss
round-trip min/avg/max = 0.157/0.186/0.214 ms
SSH is enabled.
I can connect using putty or Winscp from a windows machine.
Anyone have sugestion ?
0 Kudos
1 Solution

Accepted Solutions
jrmunday
Commander
Commander

Copied from this thread;

http://communities.vmware.com/message/2067067#2067067

You need to open the required ssh ports in the ESXi firewall.

In the vSphere Client check the host -> Configuration -> Security Profile -> Firewall -> Properties

and enable "SSH Client" if you need outgoing scp connections resp. "SSH server" if you want to enable incoming scp connections.

vExpert 2014 - 2018 | VCP6-DCV | http://www.jonmunday.net | @JonMunday77

View solution in original post

2 Replies
jrmunday
Commander
Commander

Copied from this thread;

http://communities.vmware.com/message/2067067#2067067

You need to open the required ssh ports in the ESXi firewall.

In the vSphere Client check the host -> Configuration -> Security Profile -> Firewall -> Properties

and enable "SSH Client" if you need outgoing scp connections resp. "SSH server" if you want to enable incoming scp connections.

vExpert 2014 - 2018 | VCP6-DCV | http://www.jonmunday.net | @JonMunday77

View solution in original post

alancondori
Contributor
Contributor

Thank you very much!, Now I can copy the files without any problem. -

0 Kudos