Pyme93
Contributor
Contributor

Ryzen 9 5900x localhost.localdomain %100 cpu

Pyme93_0-1610755651829.pngPyme93_1-1610755686639.png


Hello, localhost.localdomain using %100 CPU for a second . I didn't find why :S 
Is it CPU malufunction? 
My Hardware:

Manufacturer
Gigabyte Technology Co., Ltd.
Model
X570 UD
CPU
12 CPUs x AMD Ryzen 9 5900X 12-Core Processor
Memory
95.95 GB
Persistent Memory
0 B
Virtual flash
0 B used, 0 B capacity
0 Kudos
20 Replies
scott28tt
VMware Employee
VMware Employee

@Pyme93 

Moderator: Please state which VMware product you are using.

 

0 Kudos
Pyme93
Contributor
Contributor

ESXİ 6.7.0 Update 3 (Build 17167734) BTW , one of people i know has same problem in Ryzen 9 5900x 

0 Kudos
scott28tt
VMware Employee
VMware Employee

@Pyme93 

Moderator: Please try and create a thread in the area for the product used - moved to ESXi Discussions

0 Kudos
NathanosBlightc
Commander
Commander

Did you ever check the VMware HCL to consider your current hardware platform with ESXi 6.7 U3: https://www.vmware.com/resources/compatibility/search.php?deviceCategory=server&details=1&partner=10...

 

 

Please mark my comment as the Correct Answer if this solution resolved your problem
0 Kudos
Lalegre
Virtuoso
Virtuoso

Hey @Pyme93,

Well the Ryzen 9 is not server designed so from there you know that the CPU will not be in the HCL at all. However as you are using this for LAB purposes what I would to is monitor the ESXi utilization by login in and running esxtop.

As I can see this is happening almost everytime so you will be able to monitor which process is making the CPU spike.

Also you can follow the next KB to extract everything esxtop captures to a CSV file for future analysis: https://kb.vmware.com/s/article/1004953

 

Tags (1)
0 Kudos
Pyme93
Contributor
Contributor

YES it's not compatible - but I had no problem in Ryzen 9 3900x
I already tried esxtop command in first day , i tought one of Virtual machines has doing that, bu all of their CPU is limited between 2 to 6 ghz . Even if they work in full load it's impossible for them to reach %100, problem is only happening in Ryzen 9 5900x cpu, not in Ryzen 9-7-5 3rd gen CPUs . 

0 Kudos
Pyme93
Contributor
Contributor

Is there any way to limit localhost.localdomain cpu usage?  2 of my friends purchased ryzen 9 5900x and having same problem, they decided to sell their processors. Any ideas? Their Vmware Esxi crashing and causing thier pc to restart . I have no restart problem but i got serious perfomance issues. 

0 Kudos
vbondzio
VMware Employee
VMware Employee

If you tried esxtop, what was the name of the world / group that spiked? Can you power off all VMs and just monitor for that? esxtop batch collection and graphing might not work if whatever world is spiking is short lived, since esxtop batch mode implies lock mode. That means that entities that exists when the collection starts are "locked in", e.g. if you vMotion a VM to a host that you are recording esxtop batch on, it will not pick up on the new VM.

Also, is that spike coming at certain intervals? Anything else that correlates?

0 Kudos
datatelekom
Contributor
Contributor

Same problem on my 5950x server rent from hetzner. Can you fix it ? Please help. Everytime cpu peak %100 randomly. i just have 2 cloud and there is no cpu usage on them. I think cpu bug with vmware.

Tags (1)
0 Kudos
vbondzio
VMware Employee
VMware Employee

I'm looking into it, you could help by providing data that I have asked for above. If this is similar to what I am investigating currently, it shouldn't be very serious and more or less just a display / accounting issue.

0 Kudos
Pyme93
Contributor
Contributor

How can i provide you data? 

0 Kudos
Pyme93
Contributor
Contributor

How can i provide you data? ? 

0 Kudos
vbondzio
VMware Employee
VMware Employee

Screenshot of the peak (per PCPU) + esxtop batch data please. Collect ~ 60 minutes worth of regular (non all) esxtop batch, repeat until it captures the peak.

minutes=60; path="/vmfs/volumes/DATASTORE_WITH_ENOUGH_SPACE"; esxtop -ba -d 20 -n $(expr ${minutes} \* 3) > "${path}"/$(hostname)_$(date -u +"%Y-%m-%dT%H%M%S")_esxtop_batch_all.csv
0 Kudos
Pyme93
Contributor
Contributor

Sorry for late response, here is the data i collected as you asked.
CPU totaly stuck in %100  , it's becoming worst now.

0 Kudos
Pyme93
Contributor
Contributor

Pyme93_0-1619373405715.png

 

0 Kudos
Pyme93
Contributor
Contributor

BUMP+
My processor on fire:S

0 Kudos
Pyme93
Contributor
Contributor

BUMP+

0 Kudos
actck_3
Contributor
Contributor

Hi, i have a server same with this problem, any update ?

CPU: AMD Ryzen 9 5950X

MB: Asus WS Pro X570

SW: ESXI- 6.7.0 Update 3 (Build 17700523)

0 Kudos
actck_3
Contributor
Contributor

forget this post i can' delete

0 Kudos